summaryrefslogtreecommitdiff
path: root/dev-vcs/svn2git/svn2git-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-09 09:27:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-09 09:27:03 +0100
commitcb3e8c6af7661fbcafdcacc7e0ecdfb610d098fa (patch)
tree047fc92023c520d07f13ec5ac96e094d1b312a7a /dev-vcs/svn2git/svn2git-9999.ebuild
parent7b9f15840068dfaeea5684f8a1af1fe460dfa14c (diff)
gentoo resync : 09.06.2018
Diffstat (limited to 'dev-vcs/svn2git/svn2git-9999.ebuild')
-rw-r--r--dev-vcs/svn2git/svn2git-9999.ebuild19
1 files changed, 6 insertions, 13 deletions
diff --git a/dev-vcs/svn2git/svn2git-9999.ebuild b/dev-vcs/svn2git/svn2git-9999.ebuild
index 0fd35c4b742f..77393d1e3fbe 100644
--- a/dev-vcs/svn2git/svn2git-9999.ebuild
+++ b/dev-vcs/svn2git/svn2git-9999.ebuild
@@ -28,20 +28,13 @@ RDEPEND="${DEPEND}
DOCS=( README.md )
-PATCHES=( "${FILESDIR}"/${PN}-1.0.2.1-include-path.patch )
-
-src_prepare() {
- # Note: patching order matters
- default
-
- if [[ "${PV}" != "9999" ]]; then
- eapply "${FILESDIR}"/${PN}-1.0.10-version.patch
- export SVN_ALL_FAST_EXPORT_VERSION=${PVR} # for src_compile
- fi
-}
-
src_configure() {
- eqmake5 fast-export2.pro
+ local qmake_args=(
+ APR_INCLUDE=/usr/include/apr-1
+ PREFIX=/usr
+ SVN_INCLUDE=/usr/include/subversion-1
+ )
+ eqmake5 "${qmake_args[@]}" fast-export2.pro
}
src_install() {