summaryrefslogtreecommitdiff
path: root/dev-vcs/subversion/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-06 11:42:16 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-06 11:42:16 +0000
commita03b2fe2d845ae950995bf1c5255da420cbd92d2 (patch)
tree7c05b96187cce0c598ea9af9fe03ab294f4df6e5 /dev-vcs/subversion/files
parent9e0addc1cf71ebec277b59e38eb3fa30e650cf9f (diff)
gentoo auto-resync : 06:02:2024 - 11:42:15
Diffstat (limited to 'dev-vcs/subversion/files')
-rw-r--r--dev-vcs/subversion/files/subversion-1.14.3-ruby-c99.patch28
-rw-r--r--dev-vcs/subversion/files/subversion-1.5.6-aix-dso.patch21
-rw-r--r--dev-vcs/subversion/files/subversion-1.8.1-revert_bdb6check.patch85
-rw-r--r--dev-vcs/subversion/files/subversion-1.8.16-javadoc-nolint.patch19
4 files changed, 153 insertions, 0 deletions
diff --git a/dev-vcs/subversion/files/subversion-1.14.3-ruby-c99.patch b/dev-vcs/subversion/files/subversion-1.14.3-ruby-c99.patch
new file mode 100644
index 000000000000..161984f978f9
--- /dev/null
+++ b/dev-vcs/subversion/files/subversion-1.14.3-ruby-c99.patch
@@ -0,0 +1,28 @@
+https://bugs.gentoo.org/919090
+https://src.fedoraproject.org/rpms/subversion/blob/rawhide/f/subversion-ruby-c99.patch
+
+The Ruby bindings apply the Ruby NIL_P macro to an apr_hash_t * value,
+which some compilers flag as a type error.
+
+Submitted upstream: <https://issues.apache.org/jira/browse/SVN-4915>
+
+--- a/subversion/bindings/swig/include/svn_containers.swg
++++ b/subversion/bindings/swig/include/svn_containers.swg
+@@ -299,7 +299,7 @@
+ $1 = svn_swig_rb_hash_to_apr_hash_svn_string($input, _global_pool);
+ _global_pool = NULL;
+ if (!NIL_P(rb_pool)) {
+- if (NIL_P($1)) {
++ if ($1 == NULL) {
+ svn_swig_rb_destroy_pool(rb_pool);
+ } else {
+ svn_swig_rb_set_pool_for_no_swig_type($input, rb_pool);
+@@ -373,7 +373,7 @@
+ svn_swig_rb_hash_to_apr_hash_string($input, _global_pool);
+ _global_pool = NULL;
+ if (!NIL_P(rb_pool)) {
+- if (NIL_P($1)) {
++ if ($1 == NULL) {
+ svn_swig_rb_destroy_pool(rb_pool);
+ } else {
+ svn_swig_rb_set_pool_for_no_swig_type($input, rb_pool);
diff --git a/dev-vcs/subversion/files/subversion-1.5.6-aix-dso.patch b/dev-vcs/subversion/files/subversion-1.5.6-aix-dso.patch
new file mode 100644
index 000000000000..69a4355f17af
--- /dev/null
+++ b/dev-vcs/subversion/files/subversion-1.5.6-aix-dso.patch
@@ -0,0 +1,21 @@
+On AIX, load shared libraries even when created with full aix-soname support:
+http://lists.gnu.org/archive/html/libtool/2011-01/msg00023.html
+http://lists.gnu.org/archive/html/libtool/2011-02/msg00000.html
+Once there is an agreement on that, this patch eventually is for upstream too.
+
+--- a/subversion/libsvn_ra/ra_loader.c
++++ b/subversion/libsvn_ra/ra_loader.c
+@@ -164,6 +164,13 @@
+
+ /* find/load the specified library */
+ SVN_ERR(svn_dso_load(&dso, libname));
++#ifdef _AIX
++ if (! dso) {
++ libname = apr_psprintf(pool, "libsvn_ra_%s-%d.so.0(shr.o)",
++ ra_name, SVN_VER_MAJOR);
++ SVN_ERR(svn_dso_load(&dso, libname));
++ }
++#endif
+ if (! dso)
+ return SVN_NO_ERROR;
+
diff --git a/dev-vcs/subversion/files/subversion-1.8.1-revert_bdb6check.patch b/dev-vcs/subversion/files/subversion-1.8.1-revert_bdb6check.patch
new file mode 100644
index 000000000000..158c08233165
--- /dev/null
+++ b/dev-vcs/subversion/files/subversion-1.8.1-revert_bdb6check.patch
@@ -0,0 +1,85 @@
+--- subversion-1.8.1/build/ac-macros/berkeley-db.m4
++++ subversion-1.8.1/build/ac-macros/berkeley-db.m4
+@@ -48,7 +48,7 @@
+ AC_ARG_WITH(berkeley-db, [AS_HELP_STRING(
+ [[--with-berkeley-db[=HEADER:INCLUDES:LIB_SEARCH_DIRS:LIBS]]], [
+ The Subversion Berkeley DB based filesystem library
+- requires Berkeley DB $db_version or $db_alt_version. If you
++ requires Berkeley DB $db_version or newer. If you
+ specify `--without-berkeley-db', that library will
+ not be built. If you omit the argument of this option
+ completely, the configure script will use Berkeley DB
+@@ -126,35 +126,22 @@
+ svn_lib_berkeley_db=no
+ else
+ AC_MSG_CHECKING([for availability of Berkeley DB])
+- AC_ARG_ENABLE(bdb6,
+- AS_HELP_STRING([--enable-bdb6],
+- [Allow building against BDB 6+.
+- See --with-berkeley-db for specifying the location of
+- the Berkeley DB installation. Using BDB 6 will fail if
+- this option is not used.]),
+- [enable_bdb6=$enableval],[enable_bdb6=unspecified])
+-
+- SVN_LIB_BERKELEY_DB_TRY($1, $2, $3, $enable_bdb6)
++ SVN_LIB_BERKELEY_DB_TRY($1, $2, $3)
+ if test "$svn_have_berkeley_db" = "yes"; then
+ AC_MSG_RESULT([yes])
+ svn_lib_berkeley_db=yes
+ else
+- if test "$svn_have_berkeley_db" = "no6"; then
+- AC_MSG_RESULT([no (found version 6, but --enable-bdb6 not specified)])
+- # A warning will be printed at the end of configure.ac.
+- else
+- AC_MSG_RESULT([no])
+- fi
++ AC_MSG_RESULT([no])
+ svn_lib_berkeley_db=no
+ if test "$bdb_status" = "required"; then
+- AC_MSG_ERROR([Berkeley DB $db_version or $db_alt_version wasn't found.])
++ AC_MSG_ERROR([Berkeley DB $db_version or newer't found.])
+ fi
+ fi
+ fi
+ ])
+
+
+-dnl SVN_LIB_BERKELEY_DB_TRY(major, minor, patch, enable_bdb6)
++dnl SVN_LIB_BERKELEY_DB_TRY(major, minor, patch)
+ dnl
+ dnl A subroutine of SVN_LIB_BERKELEY_DB.
+ dnl
+@@ -187,7 +174,6 @@
+ svn_check_berkeley_db_major=$1
+ svn_check_berkeley_db_minor=$2
+ svn_check_berkeley_db_patch=$3
+- enable_bdb6=$4
+
+ if test -z "$SVN_DB_LIBS"; then
+ # We pass --dbm-libs here since Debian has modified apu-config not
+@@ -245,12 +231,6 @@
+ || patch != DB_VERSION_PATCH)
+ exit (1);
+
+- /* Block Berkeley DB 6, because (a) we haven't tested with it, (b) 6.0.20
+- and newer are under the AGPL, and we want use of AGPL dependencies to be
+- opt-in. */
+- if (major >= 6 && strcmp("$enable_bdb6", "yes"))
+- exit(2);
+-
+ /* Run-time check: ensure the library claims to be the correct version. */
+
+ if (major < $svn_check_berkeley_db_major)
+@@ -270,11 +250,7 @@
+ }
+ ]])],
+ [svn_have_berkeley_db=yes],
+- [rc=$?
+- svn_have_berkeley_db=no
+- if test $rc = 2; then
+- svn_have_berkeley_db=no6
+- fi],
++ [svn_have_berkeley_db=no],
+ [svn_have_berkeley_db=yes]
+ )
+
diff --git a/dev-vcs/subversion/files/subversion-1.8.16-javadoc-nolint.patch b/dev-vcs/subversion/files/subversion-1.8.16-javadoc-nolint.patch
new file mode 100644
index 000000000000..8b07d22ca3f4
--- /dev/null
+++ b/dev-vcs/subversion/files/subversion-1.8.16-javadoc-nolint.patch
@@ -0,0 +1,19 @@
+With newer versions of javadoc (since JDK-1.8), "make doc-javahl"
+reports many errors, causing build failures. Add "-Xdoclint:none"
+option to restore old, sloppy behavior.
+
+Patch created for subversion-1.8.16, should work for other other
+versions, too.
+See <https://bugs.gentoo.org/show_bug.cgi?id=551094>
+
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -650,7 +650,7 @@
+
+ # Generate API documentation for the JavaHL package.
+ doc-javahl:
+- $(JAVADOC) -d $(abs_builddir)/doc/javadoc \
++ $(JAVADOC) -Xdoclint:none -d $(abs_builddir)/doc/javadoc \
+ -sourcepath $(top_srcdir)/subversion/bindings/javahl/src \
+ -link http://java.sun.com/javase/6/docs/api/ \
+ org.tigris.subversion.javahl \