summaryrefslogtreecommitdiff
path: root/dev-vcs/stagit/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /dev-vcs/stagit/files
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'dev-vcs/stagit/files')
-rw-r--r--dev-vcs/stagit/files/stagit-1.1-pkg-config.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/dev-vcs/stagit/files/stagit-1.1-pkg-config.patch b/dev-vcs/stagit/files/stagit-1.1-pkg-config.patch
new file mode 100644
index 000000000000..f4bc82d30502
--- /dev/null
+++ b/dev-vcs/stagit/files/stagit-1.1-pkg-config.patch
@@ -0,0 +1,18 @@
+From a0fd5bc899aa6552f14a64adcce24467376062c3 Mon Sep 17 00:00:00 2001
+From: Matthew Smith <matthew@gentoo.org>
+Date: Tue, 5 Jul 2022 20:52:35 +0100
+Subject: [PATCH] build: Use pkg-config to find libgit2
+
+--- a/Makefile
++++ b/Makefile
+@@ -8,8 +8,8 @@ PREFIX = /usr/local
+ MANPREFIX = ${PREFIX}/man
+ DOCPREFIX = ${PREFIX}/share/doc/${NAME}
+
+-LIBGIT_INC = -I/usr/local/include
+-LIBGIT_LIB = -L/usr/local/lib -lgit2
++LIBGIT_INC = $(shell pkg-config --cflags libgit2)
++LIBGIT_LIB = $(shell pkg-config --libs libgit2)
+
+ # use system flags.
+ STAGIT_CFLAGS = ${LIBGIT_INC} ${CFLAGS}