summaryrefslogtreecommitdiff
path: root/dev-vcs/rsvndump/rsvndump-0.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-vcs/rsvndump/rsvndump-0.6.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-vcs/rsvndump/rsvndump-0.6.ebuild')
-rw-r--r--dev-vcs/rsvndump/rsvndump-0.6.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-vcs/rsvndump/rsvndump-0.6.ebuild b/dev-vcs/rsvndump/rsvndump-0.6.ebuild
new file mode 100644
index 000000000000..0fd269ce1768
--- /dev/null
+++ b/dev-vcs/rsvndump/rsvndump-0.6.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Dump a remote Subversion repository"
+HOMEPAGE="http://rsvndump.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3+ BSD public-domain" # rsvndump, snappy-c, critbit89
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc"
+
+RDEPEND="dev-vcs/subversion
+ dev-libs/apr
+ dev-libs/apr-util
+ sys-devel/gettext"
+DEPEND="${RDEPEND}
+ doc? ( app-text/xmlto
+ >=app-text/asciidoc-8.4 )"
+
+src_configure() {
+ econf \
+ $(use_enable doc man) \
+ $(use_enable debug)
+}