summaryrefslogtreecommitdiff
path: root/dev-vcs/repo/repo-2.32.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-17 04:08:35 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-17 04:08:35 +0100
commit43f85394ba834267589a4e6478ef419d40e22503 (patch)
treeb54082395e0e153c889b6dfe60d580a57992b3e8 /dev-vcs/repo/repo-2.32.ebuild
parentc4507bfdfd706b2b1301972490fe88ac3ddbc70e (diff)
gentoo auto-resync : 17:05:2023 - 04:08:35
Diffstat (limited to 'dev-vcs/repo/repo-2.32.ebuild')
-rw-r--r--dev-vcs/repo/repo-2.32.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-vcs/repo/repo-2.32.ebuild b/dev-vcs/repo/repo-2.32.ebuild
new file mode 100644
index 000000000000..c008c0bbe33c
--- /dev/null
+++ b/dev-vcs/repo/repo-2.32.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# NB: The ${PV} tracks the *repo launcher version*, not the last signed release
+# of the repo project. The launcher only gets a new update when changes are
+# made in it.
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit bash-completion-r1 python-r1
+
+DESCRIPTION="Google tool for managing git, particularly multiple repos"
+HOMEPAGE="https://gerrit.googlesource.com/git-repo"
+SRC_URI="https://storage.googleapis.com/git-repo-downloads/${P}
+ https://github.com/GerritCodeReview/git-repo/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ !app-admin/radmind
+"
+
+S="${WORKDIR}/git-${P}"
+
+src_install() {
+ python_foreach_impl python_newscript "${DISTDIR}/${P}" ${PN}
+ newbashcomp completion.bash ${PN}
+ doman man/*.[0-9]
+}