summaryrefslogtreecommitdiff
path: root/dev-vcs/rabbitvcs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-vcs/rabbitvcs
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-vcs/rabbitvcs')
-rw-r--r--dev-vcs/rabbitvcs/Manifest3
-rw-r--r--dev-vcs/rabbitvcs/metadata.xml24
-rw-r--r--dev-vcs/rabbitvcs/rabbitvcs-0.16-r1.ebuild101
3 files changed, 128 insertions, 0 deletions
diff --git a/dev-vcs/rabbitvcs/Manifest b/dev-vcs/rabbitvcs/Manifest
new file mode 100644
index 000000000000..73ea73e1f749
--- /dev/null
+++ b/dev-vcs/rabbitvcs/Manifest
@@ -0,0 +1,3 @@
+DIST rabbitvcs-0.16.tar.gz 1670167 BLAKE2B 44d60de0bf6beb659fe8c8d1dffdb35d1a767e47a6c9aa26515e70e46d888f4394512d2b407f9f0b28edc501392ea873dfbf44dd858169ef1943cf1e02f0eaf1 SHA512 dac3b98acb5b7ef1147105aa0f735bb964c098f764c62d0e2e601a2ce34b315a5c83b3bac8929cbac898f674c86266a200f28042aad0340c1c5273bec4a6279c
+EBUILD rabbitvcs-0.16-r1.ebuild 3116 BLAKE2B e0a939bda5471cc3fd44aa2e14fbd7d0d0059b76b83e1063dc7d5384ba84cd1f2948c8566117cafc1abd50b640072af9b2c6a5efd8db684e3fb77fce18f1a6c6 SHA512 ba042954748dc63ab64bae55241363d726126033f51e51a0c055c5a7c67a7b702d4831603d5c37613ad658c4d85708af78905fe9d2437645756f1b46027173f2
+MISC metadata.xml 1006 BLAKE2B 033fb349c1e1e5d9166014b8f241cd9dbdcc8483c25bc88d762b8e68f99acfdf7740d7cad7f404731f60dfee123c7f758079eba5ad61a74bed6c103682101489 SHA512 99879d14ad0c09948e11dc70c304798954e062c09b5679e3af86d6c92cda5f0be5b40012f0838285371bc1b6a5446c364d45c64fcf75a0cfe23f984d24188f1b
diff --git a/dev-vcs/rabbitvcs/metadata.xml b/dev-vcs/rabbitvcs/metadata.xml
new file mode 100644
index 000000000000..a2d833d6ca7d
--- /dev/null
+++ b/dev-vcs/rabbitvcs/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xmw@gentoo.org</email>
+ <name>Michael Weber</name>
+ </maintainer>
+ <longdescription>
+ RabbitVCS is a set of graphical tools written to provide
+ simple and straightforward access to the version control systems you use.
+ RabbitVCS is inspired by TortoiseSVN and others.
+ </longdescription>
+ <use>
+ <flag name="caja">Enable extension for <pkg>mate-base/caja</pkg></flag>
+ <flag name="cli">Eanble console based frontend</flag>
+ <flag name="diff">Use for diff command <pkg>dev-util/meld</pkg></flag>
+ <flag name="gedit">Enable plugin for <pkg>app-editors/gedit</pkg></flag>
+ <flag name="nautilus">Enable extension for <pkg>gnome-base/nautilus</pkg></flag>
+ <flag name="thunar">Enable extension for <pkg>xfce-base/thunar</pkg></flag>
+ </use>
+ <upstream>
+ <remote-id type="github">rabbitvcs/rabbitvcs</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-vcs/rabbitvcs/rabbitvcs-0.16-r1.ebuild b/dev-vcs/rabbitvcs/rabbitvcs-0.16-r1.ebuild
new file mode 100644
index 000000000000..f9e95ffff779
--- /dev/null
+++ b/dev-vcs/rabbitvcs/rabbitvcs-0.16-r1.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit gnome2-utils distutils-r1 vcs-snapshot
+
+DESCRIPTION="Integrated version control support for your desktop"
+HOMEPAGE="http://rabbitvcs.org"
+SRC_URI="https://github.com/rabbitvcs/${PN}/tarball/v${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="caja cli diff gedit git nautilus spell thunar"
+
+RDEPEND="dev-python/configobj[${PYTHON_USEDEP}]
+ dev-python/pygobject:2[${PYTHON_USEDEP}]
+ dev-python/pygtk[${PYTHON_USEDEP}]
+ dev-python/pysvn[${PYTHON_USEDEP}]
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ caja? ( dev-python/python-caja[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/gnome-vfs-python[${PYTHON_USEDEP}] )
+ diff? ( dev-util/meld )
+ gedit? ( app-editors/gedit[${PYTHON_USEDEP}] )
+ git? ( dev-python/dulwich[${PYTHON_USEDEP}] )
+ nautilus? ( >=dev-python/nautilus-python-0.7.0[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/gnome-vfs-python[${PYTHON_USEDEP}] )
+ spell? ( dev-python/gtkspell-python[${PYTHON_USEDEP}] )
+ thunar? ( dev-python/thunarx-python[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+# python_convert_shebangs -r 2 .
+
+# distutils_src_prepare
+
+ # we should not do gtk-update-icon-cache from setup script
+ # we prefer portage for that
+ sed -e 's/"install"/"fakeinstall"/' -i "${S}/setup.py" || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ if use caja ; then
+ python_moduleinto /usr/share/caja-python/extensions
+ python_domodule clients/caja/RabbitVCS.py
+ fi
+ if use cli ; then
+ python_doscript clients/cli/rabbitvcs
+ fi
+ if use gedit ; then
+ python_moduleinto /usr/$(get_libdir)/gedit-2/plugins
+ python_domodule clients/gedit/rabbitvcs-plugin.py
+ insinto /usr/$(get_libdir)/gedit-2/plugins
+ doins clients/gedit/rabbitvcs-gedit2.gedit-plugin
+ python_moduleinto /usr/$(get_libdir)/gedit-2/plugins
+ python_domodule clients/gedit/rabbitvcs-plugin.py
+ insinto /usr/$(get_libdir)/gedit/plugins
+ doins clients/gedit/rabbitvcs-gedit3.plugin
+ fi
+ if use nautilus ; then
+ python_moduleinto /usr/$(get_libdir)/nautilus/extensions-2.0/python
+ python_domodule clients/nautilus/RabbitVCS.py
+ python_moduleinto /usr/share/nautilus-python/extensions
+ python_domodule clients/nautilus-3.0/RabbitVCS.py
+ fi
+ if use thunar ; then
+ python_moduleinto "/usr/$(get_libdir)/thunarx-2/python"
+ python_domodule clients/thunar/RabbitVCS.py
+ python_moduleinto "/usr/$(get_libdir)/thunarx-1/python"
+ python_domodule clients/thunar/RabbitVCS.py
+ fi
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+
+ elog "You should restart file manager to changes take effect:"
+ use caja && elog "\$ caja -q"
+ use nautilus && elog "\$ nautilus -q"
+ use thunar && elog "\$ thunar -q && thunar &"
+ elog ""
+ elog "Also you should really look at known issues page:"
+ elog "http://wiki.rabbitvcs.org/wiki/support/known-issues"
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}