summaryrefslogtreecommitdiff
path: root/dev-vcs/python-gitlab
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-31 18:57:01 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-31 18:57:01 +0000
commit69051588e2f955485fe5d45d45e616bc60a2de57 (patch)
treeef8699cca7ce3773b1de747b167ceeacdc60cb92 /dev-vcs/python-gitlab
parentd7ed2b01311f15ba54fe8ea872aab7d59ab2b193 (diff)
gentoo resync : 31.01.2021
Diffstat (limited to 'dev-vcs/python-gitlab')
-rw-r--r--dev-vcs/python-gitlab/Manifest4
-rw-r--r--dev-vcs/python-gitlab/python-gitlab-2.5.0.ebuild2
-rw-r--r--dev-vcs/python-gitlab/python-gitlab-2.6.0.ebuild36
3 files changed, 40 insertions, 2 deletions
diff --git a/dev-vcs/python-gitlab/Manifest b/dev-vcs/python-gitlab/Manifest
index 84fe756111de..244c38496ff4 100644
--- a/dev-vcs/python-gitlab/Manifest
+++ b/dev-vcs/python-gitlab/Manifest
@@ -1,3 +1,5 @@
DIST python-gitlab-2.5.0.tar.gz 148916 BLAKE2B f870833a01adac08b71dc402bc11ba9c1be19c920735faf04de9bfca3b1a154706da4bc0475437997e3b03d8c9a56977a6691df05b750d64a1f8b964ecd05612 SHA512 7382f9ea2388c6916f3c7e63df137d73f0fdfb3890a8bbb47e766f3476b6febecd1dcbc588445ae1af1b5f17c9a3e6ed9a931fd9fff010c2c37967eab5440824
-EBUILD python-gitlab-2.5.0.ebuild 806 BLAKE2B 068b38234ea175c04fde4d825837331436a29a4c140cb6eed8beea66e1bf548f8634ff903d026a6b6c4418a1fdfc66ae063d8fd9d9cb29141057c0571b0bd640 SHA512 89d2709fc88963d76996f033f9360bbd8a341ea8e6181334cef17ab8796e73efaac79c46e825e3fd1c6732270d96be3a273091571e97bdff0c8ad6a8ab9ffe10
+DIST python-gitlab-2.6.0.tar.gz 153577 BLAKE2B 4fa0206faa601061fde257988362eca962c9e20f50e5ad57d602a76618581db646f26b035d4d86b9c460ef75f241fcbcdf360419b2e62ec6f95a664ab237d7d2 SHA512 b63dd4657b44fb484d114ceddc1d67465c17560978a8e6b09a9b14634ae6d80bf864b9b4583ddfc102c27c1082f4a015958c30944a734ec635761af524956fbe
+EBUILD python-gitlab-2.5.0.ebuild 804 BLAKE2B 6f5ebdb0b2aa68916406be761995a4ef0c02ac4d62a9790f60a7a03a007c5d22a596cd937f98b1b613c48cbcfeafd640d83688760287ad63ca1fa02b90f9b72e SHA512 796675f445b95e875facf3e35d90847cd36b111e57b264df058bc5debec35a3a358840921497d467da0e7b37dc8c1f7c0b96b00fd3a45b141a77d5442a3df803
+EBUILD python-gitlab-2.6.0.ebuild 869 BLAKE2B 81cbe2002567ccf074b02aa8c4a9e770c0b5c4ee84df49bd9526730bbe35b9639133b0f11a27792b15b43553052177ee95350d529b6c174bdc1a9c9f16e0c280 SHA512 717a234093a1c15f136ddf7f58a683c4c0583d684acb06f632f8eaf78ca910692f33bbc8a6e2af5a75851cd75392dcf4fc152b48a6f4b75a6d0283011420a6c0
MISC metadata.xml 248 BLAKE2B 5d9c3678c604aac0f24c5d5015e28f02b9ce83bb6a179755a44adeb3d69e4dd50be4acc30a6317649f5be23bcf13ac210bbe4712aa403e9c4cf2de351b39c941 SHA512 dc5b06a888be6367909895d5891a08189f4657bcee602e5ff0021be2ad3677e58ec7387ff244625be66a142138666e7eac790d2a7b1e298f0ad644725b5e57e0
diff --git a/dev-vcs/python-gitlab/python-gitlab-2.5.0.ebuild b/dev-vcs/python-gitlab/python-gitlab-2.5.0.ebuild
index fb687ff4c2f1..3640bc378d3f 100644
--- a/dev-vcs/python-gitlab/python-gitlab-2.5.0.ebuild
+++ b/dev-vcs/python-gitlab/python-gitlab-2.5.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{7,8} )
DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
diff --git a/dev-vcs/python-gitlab/python-gitlab-2.6.0.ebuild b/dev-vcs/python-gitlab/python-gitlab-2.6.0.ebuild
new file mode 100644
index 000000000000..615fc53453b9
--- /dev/null
+++ b/dev-vcs/python-gitlab/python-gitlab-2.6.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Python command line interface to gitlab API"
+HOMEPAGE="https://github.com/python-gitlab/python-gitlab/"
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/python-gitlab/python-gitlab"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="LGPL-3"
+SLOT="0"
+IUSE="test"
+
+BDEPEND="test? (
+ dev-python/httmock[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}] )"
+
+RDEPEND=">=dev-python/requests-2.25.1[${PYTHON_USEDEP}]
+ >=dev-python/requests-toolbelt-0.9.1[${PYTHON_USEDEP}]"
+
+distutils_enable_tests unittest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ dodoc -r *.rst docs
+}