summaryrefslogtreecommitdiff
path: root/dev-vcs/pre-commit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-10 04:21:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-10 04:21:55 +0100
commit677b7ba5c317778df2ad7e70df94b9b7eec4adbc (patch)
tree6c418a1546fff5becab5d8b9ed6803323e7f316e /dev-vcs/pre-commit
parentfbda87924e6faa7a1919f1a2b4182490bde5ec5c (diff)
gentoo resync : 10.09.2021
Diffstat (limited to 'dev-vcs/pre-commit')
-rw-r--r--dev-vcs/pre-commit/Manifest2
-rw-r--r--dev-vcs/pre-commit/pre-commit-2.15.0.ebuild58
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-vcs/pre-commit/Manifest b/dev-vcs/pre-commit/Manifest
index a6a0a26f5ccb..d5c5b2ec9e06 100644
--- a/dev-vcs/pre-commit/Manifest
+++ b/dev-vcs/pre-commit/Manifest
@@ -1,3 +1,5 @@
DIST pre-commit-2.13.0.tar.gz 252631 BLAKE2B 7e6b3af46dfaf9928d2cb2aa6cad05423bf6e417e2324af71b241e1aaa2eec6fcb271869f98c040cd4fb8c608a1fabd244c8286864f469a06c44684cd2bf33eb SHA512 5dfc297b3f900afef8f1c355b38ce086af7c836d1e577af8ec95ffb30e82df8b866131da4ff12933339bda63e4a90833c3852265d4f2d4a59bf92bce2b972a5e
+DIST pre-commit-2.15.0.tar.gz 255545 BLAKE2B 8fbb1fd6b1298ff1c5a6884dae53c79d108e8c4b74d05d6be36d562327fd024432d60e6df4570217e1b3f4ad8e33ee4d0d54a5d940f4833a46d4e9cb59698b3c SHA512 b87985aa625509d7a21e31e5774f259c264ec74fef88fc5e290cbac0326cdbadc37ab54b5bf3048d815cf9bc6d4adb71619fcb84c955c1bc9741da8dfd34251c
EBUILD pre-commit-2.13.0.ebuild 2089 BLAKE2B be856789c2a63790f0ea56a91dabf75f9e808b15f7c1d8e347e72cd097209c46d19496c176c707eec4299a2732415176286349cec08e764e05a2c73265fe51f1 SHA512 9f697bb93155a308769f4f2b52f6f9c7681b76755300c96c4d92d575e14d34151f9c33cd8fe5a79888edab526bcd886e867d9f8d8f1f4d3f18fc457944943fb9
+EBUILD pre-commit-2.15.0.ebuild 2057 BLAKE2B 23703ee52a93324becf1034482cb68588cb7b9a91a87e7190151729ef7131174bd5345d010cae4cf30f2abb3a9ca9ade0a6baf23182f156d5b55bbd93e3a8d08 SHA512 f8b6531fb9b823c4b03b3a9667387808bc4e527c78afe8c0ed24a5849f6b5c554cdd84ff85e52d69463466f7272bf6999e7d337c6f1befd827ac80d53d40ec78
MISC metadata.xml 379 BLAKE2B 6224574b28f758241c6ad965ad59a423db76bd21c64c3577691104a8f45a4ee9b570f9cf1557f2ce17f00bf496b9eeb83741679dc0d6e1bb23c421f90fe9070f SHA512 f14032e386c2bb591390034086c7d4a2e8ce9aacc536574c517dff4691aa8c39bc966307ee91a5f76708f14601312fd16528a676e1918d82b2761185bc27df9f
diff --git a/dev-vcs/pre-commit/pre-commit-2.15.0.ebuild b/dev-vcs/pre-commit/pre-commit-2.15.0.ebuild
new file mode 100644
index 000000000000..79480395678d
--- /dev/null
+++ b/dev-vcs/pre-commit/pre-commit-2.15.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_SINGLE_IMPL=1
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+DESCRIPTION="A framework for managing and maintaining multi-language Git pre-commit hooks"
+HOMEPAGE="https://pre-commit.com/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+
+# TODO: figure out why these tests - all of which invoke git - fail:
+# - tests/main_test.py::test_all_cmds[autoupdate,hook-impl,install,install-hooks,migrate-config,run,uninstall],
+# tests/main_test.py::test_try_repo:
+# Calling "git rev-parse" fails with "fatal: not a git repository (or any of the parent directories): .git".
+# NOT a sandbox issue it seems, as disabling it does not help.
+# - tests/commands/install_uninstall_test.py::test_environment_not_sourced:
+# Unexpected error "/usr/bin/env: 'python3.8': No such file or directory" - but only if pre-commit
+# has previously been installed.
+# - tests/commands/install_uninstall_test.py::test_installed_from_venv:
+# the function invoking "git commit" returns 1 instead of 0, no details.
+RESTRICT="test"
+
+RDEPEND="dev-vcs/git
+ $(python_gen_cond_dep '
+ dev-python/cfgv[${PYTHON_USEDEP}]
+ dev-python/identify[${PYTHON_USEDEP}]
+ dev-python/nodeenv[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-20.0.8[${PYTHON_USEDEP}]
+ ')"
+BDEPEND="test? (
+ $(python_gen_cond_dep '
+ dev-python/pytest-env[${PYTHON_USEDEP}]
+ dev-python/re-assert[${PYTHON_USEDEP}]
+ ')
+)"
+
+DOCS=( CHANGELOG.md CONTRIBUTING.md README.md )
+
+distutils_enable_tests --install pytest
+
+src_prepare() {
+ default
+
+ # These tests require a boatload of dependencies (e.g. Conda, Go, R and more) in order to run
+ # and while some of them do include "skip if not found" logic, most of them do not.
+ rm -rf tests/languages tests/repository_test.py
+}