summaryrefslogtreecommitdiff
path: root/dev-vcs/mercurial/mercurial-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /dev-vcs/mercurial/mercurial-9999.ebuild
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'dev-vcs/mercurial/mercurial-9999.ebuild')
-rw-r--r--dev-vcs/mercurial/mercurial-9999.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-vcs/mercurial/mercurial-9999.ebuild b/dev-vcs/mercurial/mercurial-9999.ebuild
index 8c12d545eb87..a62bf9062fdc 100644
--- a/dev-vcs/mercurial/mercurial-9999.ebuild
+++ b/dev-vcs/mercurial/mercurial-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6..7} )
+PYTHON_COMPAT=( python2_7 python3_{6..8} )
PYTHON_REQ_USE="threads(+)"
inherit bash-completion-r1 elisp-common eutils distutils-r1 mercurial flag-o-matic
@@ -15,7 +15,7 @@ EHG_REPO_URI="https://www.mercurial-scm.org/repo/hg"
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS=""
-IUSE="+chg bugzilla emacs gpg test tk zsh-completion"
+IUSE="+chg emacs gpg test tk zsh-completion"
BROKEN_PYTHON="
!~dev-python/python-3.5.0
@@ -57,7 +57,7 @@ python_prepare_all() {
}
python_compile() {
- strip-flags -ftracer -ftree-vectorize
+ filter-flags -ftracer -ftree-vectorize
python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
distutils-r1_python_compile build_ext --no-zstd
}