summaryrefslogtreecommitdiff
path: root/dev-vcs/mercurial/mercurial-5.8.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /dev-vcs/mercurial/mercurial-5.8.1.ebuild
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'dev-vcs/mercurial/mercurial-5.8.1.ebuild')
-rw-r--r--dev-vcs/mercurial/mercurial-5.8.1.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/dev-vcs/mercurial/mercurial-5.8.1.ebuild b/dev-vcs/mercurial/mercurial-5.8.1.ebuild
index 40001869a2f6..bed3532e284f 100644
--- a/dev-vcs/mercurial/mercurial-5.8.1.ebuild
+++ b/dev-vcs/mercurial/mercurial-5.8.1.ebuild
@@ -127,7 +127,7 @@ zstd-safe-2.0.5+zstd.1.4.5
zstd-sys-1.4.17+zstd.1.4.5
"
-inherit bash-completion-r1 cargo elisp-common distutils-r1 flag-o-matic multiprocessing
+inherit bash-completion-r1 cargo elisp-common distutils-r1 flag-o-matic multiprocessing toolchain-funcs
DESCRIPTION="Scalable distributed SCM"
HOMEPAGE="https://www.mercurial-scm.org/"
@@ -269,6 +269,13 @@ src_test() {
rm -f test-convert-tla* # GNU Arch tla
rm -f test-largefiles* # tends to time out
rm -f test-https* # requires to support tls1.0
+ if [[ $(tc-endian) == "big" ]]; then
+ # tests no working on big-endian
+ # https://bz.mercurial-scm.org/show_bug.cgi?id=6607
+ rm -f test-clone-uncompressed.t
+ rm -f test-generaldelta.t
+ rm -f test-persistent-nodemap.t
+ fi
if [[ ${EUID} -eq 0 ]]; then
einfo "Removing tests which require user privileges to succeed"
rm -f test-convert*