summaryrefslogtreecommitdiff
path: root/dev-vcs/mercurial-server
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-vcs/mercurial-server
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-vcs/mercurial-server')
-rw-r--r--dev-vcs/mercurial-server/Manifest4
-rw-r--r--dev-vcs/mercurial-server/mercurial-server-1.2-r1.ebuild82
-rw-r--r--dev-vcs/mercurial-server/mercurial-server-9999.ebuild82
-rw-r--r--dev-vcs/mercurial-server/metadata.xml13
4 files changed, 181 insertions, 0 deletions
diff --git a/dev-vcs/mercurial-server/Manifest b/dev-vcs/mercurial-server/Manifest
new file mode 100644
index 000000000000..1c51a42d0afc
--- /dev/null
+++ b/dev-vcs/mercurial-server/Manifest
@@ -0,0 +1,4 @@
+DIST mercurial-server_1.2.tar.gz 21560 BLAKE2B 60d7dd9d0fdb55fc82d8cd268ab7ec7a53b1ba425c28520bff2f4920c1e404fbe0c0bb11e4af34b1952a8cdb2f44cecba1b5f29c6c5d85f49e992bd31cd88c1d SHA512 3dec14309fc050fa49ffd5253a491b2d65507ed8da04741ba5247d420701a9f836a1c3ef6924a706671e28bafbe0200af03c817184e303179002419887400ce0
+EBUILD mercurial-server-1.2-r1.ebuild 1785 BLAKE2B b0de1d1d1d479b94a9e277ac8f29ae2c113e727e2e3b06ca00561d83460e7b7e8d61b94bab58c187d2cfe5534210c6a29aba37f05580b48ec14873dda3d12e0a SHA512 151e85d1fddcfea7b3d23d3619a3ae48417a01e21becfeeb293742d46a96197185c8eebfa7aa4d60a47ecf472d814a846a044c0e19a47ee9a656b4998dfe4020
+EBUILD mercurial-server-9999.ebuild 1780 BLAKE2B 32a3bcbac38dbf215f747af3cef0797a3b2d6192cb91919030bc3c8a13b1844364be6bee1635d97693719ef0af836089b31454caed14c8eda9a208bedb674cf3 SHA512 a857790b3f3d1261146302bfeaa22a4e17b503ef59d7b94b85cf6b58dc7df8ccd069e66e6002032b6078de8d83537c71232f633b3fe43f182f14b594e0bc4177
+MISC metadata.xml 526 BLAKE2B 52da18d729cb3361bd21fbf46cad7561ffa3ea624b1323e05523832ac9f7a6d83af2d9a4ae02658aeb28c7f9266bfddf640f5ab1623103f3365d4c32435ca5a4 SHA512 b10db22126af52b4d38754d846fffdbcf529ca2c86b6f5bb59d19343762e2df48324e4e2dc6d72c191b54f48a89fcf753253639c7f043cb6eb27e76d70391a29
diff --git a/dev-vcs/mercurial-server/mercurial-server-1.2-r1.ebuild b/dev-vcs/mercurial-server/mercurial-server-1.2-r1.ebuild
new file mode 100644
index 000000000000..ab1be829c3fe
--- /dev/null
+++ b/dev-vcs/mercurial-server/mercurial-server-1.2-r1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# force single impl to avoid python-exec wrapping
+DISTUTILS_SINGLE_IMPL=1
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 user
+
+if [[ "${PV}" = "9999" ]]; then
+ inherit mercurial
+ EHG_REPO_URI="http://hg.opensource.lshift.net/mercurial-server"
+ KEYWORDS=""
+else
+ MY_P="${PN}_${PV}"
+ SRC_URI="http://dev.lshift.net/paul/mercurial-server/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${MY_P}.orig"
+fi
+
+DESCRIPTION="Mercurial authentication and authorization tools"
+HOMEPAGE="http://www.lshift.net/mercurial-server.html"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="doc"
+
+RDEPEND="dev-vcs/mercurial"
+DEPEND="${RDEPEND}
+ doc? (
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ )"
+
+pkg_setup() {
+ enewgroup hg
+ enewuser hg -1 /bin/bash "/var/lib/${PN}" hg
+ python-single-r1_pkg_setup
+}
+
+python_prepare_all() {
+ # remove useless makefile
+ rm Makefile || die
+
+ # fix installation paths
+ sed -i -e "s|'init'|'share/${PN}/init'|" setup.py \
+ || die 'sed setup.py failed.'
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ # build documentation
+ if use doc; then
+ xsltproc --nonet -o manual.html \
+ /usr/share/sgml/docbook/xsl-stylesheets/html/docbook.xsl \
+ doc/manual.docbook || die "xsltproc failed"
+ fi
+}
+
+python_install() {
+ distutils-r1_python_install --install-scripts="/usr/share/${PN}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ # install configuration files
+ insinto "/etc/${PN}"
+ doins -r src/init/conf/.
+ keepdir /etc/mercurial-server/keys/{root,users}
+
+ # install documentation
+ use doc && dodoc manual.html
+
+ # install hg home directory
+ keepdir "/var/lib/${PN}"
+ fowners hg:hg "/var/lib/${PN}"
+ fperms 750 "/var/lib/${PN}"
+}
diff --git a/dev-vcs/mercurial-server/mercurial-server-9999.ebuild b/dev-vcs/mercurial-server/mercurial-server-9999.ebuild
new file mode 100644
index 000000000000..701b33206779
--- /dev/null
+++ b/dev-vcs/mercurial-server/mercurial-server-9999.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# force single impl to avoid python-exec wrapping
+DISTUTILS_SINGLE_IMPL=1
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 user
+
+if [[ "${PV}" = "9999" ]]; then
+ inherit mercurial
+ EHG_REPO_URI="http://hg.opensource.lshift.net/mercurial-server"
+ KEYWORDS=""
+else
+ MY_P="${PN}_${PV}"
+ SRC_URI="http://dev.lshift.net/paul/mercurial-server/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+DESCRIPTION="Mercurial authentication and authorization tools"
+HOMEPAGE="http://www.lshift.net/mercurial-server.html"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="doc"
+
+RDEPEND="dev-vcs/mercurial"
+DEPEND="${RDEPEND}
+ doc? (
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ )"
+
+pkg_setup() {
+ enewgroup hg
+ enewuser hg -1 /bin/bash "/var/lib/${PN}" hg
+ python-single-r1_pkg_setup
+}
+
+python_prepare_all() {
+ # remove useless makefile
+ rm Makefile || die
+
+ # fix installation paths
+ sed -i -e "s|'init'|'share/${PN}/init'|" setup.py \
+ || die 'sed setup.py failed.'
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ # build documentation
+ if use doc; then
+ xsltproc --nonet -o manual.html \
+ /usr/share/sgml/docbook/xsl-stylesheets/html/docbook.xsl \
+ doc/manual.docbook || die "xsltproc failed"
+ fi
+}
+
+python_install() {
+ distutils-r1_python_install --install-scripts="/usr/share/${PN}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ # install configuration files
+ insinto "/etc/${PN}"
+ doins -r src/init/conf/.
+ keepdir /etc/mercurial-server/keys/{root,users}
+
+ # install documentation
+ use doc && dodoc manual.html
+
+ # install hg home directory
+ keepdir "/var/lib/${PN}"
+ fowners hg:hg "/var/lib/${PN}"
+ fperms 750 "/var/lib/${PN}"
+}
diff --git a/dev-vcs/mercurial-server/metadata.xml b/dev-vcs/mercurial-server/metadata.xml
new file mode 100644
index 000000000000..16b6109563df
--- /dev/null
+++ b/dev-vcs/mercurial-server/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>rafaelmartins@gentoo.org</email>
+ <name>Rafael G. Martins</name>
+ </maintainer>
+ <longdescription lang="en">
+ mercurial-server gives your developers remote read/write access to
+ centralized Mercurial repositories using SSH public key authentication; it
+ provides convenient and fine-grained key management and access control.
+ </longdescription>
+</pkgmetadata>