summaryrefslogtreecommitdiff
path: root/dev-vcs/hg-evolve/hg-evolve-11.0.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-15 16:40:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-15 16:40:41 +0100
commit35d4e80ab08982deb97a95d1b47156c67b268492 (patch)
tree52930de679b53a2d0e6881a4b18305fa1b9c5466 /dev-vcs/hg-evolve/hg-evolve-11.0.2.ebuild
parent9b6120d8af003bb775da6737dfe42f8f580f59f6 (diff)
gentoo auto-resync : 15:07:2023 - 16:40:40
Diffstat (limited to 'dev-vcs/hg-evolve/hg-evolve-11.0.2.ebuild')
-rw-r--r--dev-vcs/hg-evolve/hg-evolve-11.0.2.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-vcs/hg-evolve/hg-evolve-11.0.2.ebuild b/dev-vcs/hg-evolve/hg-evolve-11.0.2.ebuild
new file mode 100644
index 000000000000..c965944d3b48
--- /dev/null
+++ b/dev-vcs/hg-evolve/hg-evolve-11.0.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{9..12} )
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="enables the changeset evolution feature of Mercurial"
+HOMEPAGE="https://www.mercurial-scm.org/doc/evolution/"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="
+ >=dev-vcs/mercurial-4.8[${PYTHON_USEDEP}]
+ $(python_gen_impl_dep sqlite)"
+DEPEND="${RDEPEND}
+ doc? (
+ dev-python/sphinx
+ media-gfx/imagemagick[svg]
+ )"
+
+python_prepare_all() {
+ rm hgext3rd/__init__.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs all
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use doc; then
+ dodoc -r html/
+ fi
+}