summaryrefslogtreecommitdiff
path: root/dev-vcs/git/git-2.21.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
commitb7ebc951da8800f711142f69d9d958bde67a112d (patch)
treee318514216845acb8f2e49fff7a5cba4027e9d91 /dev-vcs/git/git-2.21.0-r1.ebuild
parentdc7cbdfa65fd814b3b9aa3c56257da201109e807 (diff)
gentoo resync : 28.04.2019
Diffstat (limited to 'dev-vcs/git/git-2.21.0-r1.ebuild')
-rw-r--r--dev-vcs/git/git-2.21.0-r1.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/dev-vcs/git/git-2.21.0-r1.ebuild b/dev-vcs/git/git-2.21.0-r1.ebuild
index da10d81239ce..dfad3a4abfcb 100644
--- a/dev-vcs/git/git-2.21.0-r1.ebuild
+++ b/dev-vcs/git/git-2.21.0-r1.ebuild
@@ -69,6 +69,7 @@ CDEPEND="
webdav? ( dev-libs/expat )
)
emacs? ( virtual/emacs )
+ iconv? ( virtual/libiconv )
"
RDEPEND="${CDEPEND}
@@ -164,7 +165,7 @@ exportmakeopts() {
$(usex perl 'INSTALLDIRS=vendor NO_PERL_CPAN_FALLBACKS=YesPlease' NO_PERL=YesPlease)
$(usex python '' NO_PYTHON=YesPlease)
$(usex subversion '' NO_SVN_TESTS=YesPlease)
- $(usex threads THREADED_DELTA_SEARCH=YesPlease NO_PTHREAD=YesPlease)
+ $(usex threads '' NO_PTHREAD=YesPlease)
$(usex tk '' NO_TCLTK=YesPlease)
)
@@ -241,8 +242,10 @@ exportmakeopts() {
# Bug 290465:
# builtin-fetch-pack.c:816: error: 'struct stat' has no member named 'st_mtim'
- [[ "${CHOST}" == *-uclibc* ]] && \
+ if [[ "${CHOST}" == *-uclibc* ]] ; then
myopts+=( NO_NSEC=YesPlease )
+ use iconv && myopts+=( NEEDS_LIBICONV=YesPlease )
+ fi
export MY_MAKEOPTS="${myopts[@]}"
export EXTLIBS="${extlibs[@]}"