summaryrefslogtreecommitdiff
path: root/dev-vcs/git-spindle/git-spindle-3.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-vcs/git-spindle/git-spindle-3.3-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-vcs/git-spindle/git-spindle-3.3-r1.ebuild')
-rw-r--r--dev-vcs/git-spindle/git-spindle-3.3-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-vcs/git-spindle/git-spindle-3.3-r1.ebuild b/dev-vcs/git-spindle/git-spindle-3.3-r1.ebuild
new file mode 100644
index 000000000000..7d970a8cd2ff
--- /dev/null
+++ b/dev-vcs/git-spindle/git-spindle-3.3-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Git subcommands for interacting with central services"
+HOMEPAGE="http://seveas.github.io/git-spindle/"
+SRC_URI="https://github.com/seveas/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ dev-vcs/git
+ dev-python/github3[${PYTHON_USEDEP}]
+ dev-python/docopt[${PYTHON_USEDEP}]
+ dev-python/whelk[${PYTHON_USEDEP}]
+ ${PYTHON_DEPS}"
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"