summaryrefslogtreecommitdiff
path: root/dev-vcs/git-repair/git-repair-1.20220404.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-06 12:11:06 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-06 12:11:06 +0000
commit29efd7db303b443e103311cc0e458ee5c134e8e5 (patch)
treecb6e3ef15df82575a93cae8bd11b635d473f3796 /dev-vcs/git-repair/git-repair-1.20220404.ebuild
parent19a808581ca18addf4b12d09f7e440b7244679e5 (diff)
gentoo auto-resync : 06:01:2023 - 12:11:06
Diffstat (limited to 'dev-vcs/git-repair/git-repair-1.20220404.ebuild')
-rw-r--r--dev-vcs/git-repair/git-repair-1.20220404.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-vcs/git-repair/git-repair-1.20220404.ebuild b/dev-vcs/git-repair/git-repair-1.20220404.ebuild
new file mode 100644
index 000000000000..24c70ff87dd1
--- /dev/null
+++ b/dev-vcs/git-repair/git-repair-1.20220404.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.0.0
+
+CABAL_FEATURES="haddock hoogle profile"
+inherit haskell-cabal
+
+DESCRIPTION="A tool to repair damaged git repositories"
+HOMEPAGE="https://git-repair.branchable.com/"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+GHC_BOOTSTRAP_PACKAGES=(
+ async
+ data-default
+ filepath-bytestring
+ hslogger
+ IfElse
+ split
+ time
+ unix-compat
+)
+
+RDEPEND="
+ dev-haskell/async:=[profile?]
+ dev-haskell/attoparsec:=[profile?]
+ dev-haskell/data-default:=[profile?]
+ >=dev-haskell/filepath-bytestring-1.4.2.1.4:=[profile?]
+ dev-haskell/hslogger:=[profile?]
+ dev-haskell/ifelse:=[profile?]
+ >=dev-haskell/network-2.6:=[profile?]
+ >=dev-haskell/network-uri-2.6:=[profile?]
+ >=dev-haskell/optparse-applicative-0.14.1:=[profile?]
+ dev-haskell/quickcheck:2=[profile?]
+ dev-haskell/split:=[profile?]
+ >=dev-haskell/unix-compat-0.5:=[profile?]
+ dev-haskell/utf8-string:=[profile?]
+ >=dev-lang/ghc-8.10.1:=[profile?]
+"
+DEPEND="
+ ${RDEPEND}
+ >=dev-haskell/cabal-3.2.0.0
+"
+
+src_install() {
+ haskell-cabal_src_install
+ doman git-repair.1
+}