summaryrefslogtreecommitdiff
path: root/dev-vcs/git-publish/git-publish-1.8.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-vcs/git-publish/git-publish-1.8.0.ebuild
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-vcs/git-publish/git-publish-1.8.0.ebuild')
-rw-r--r--dev-vcs/git-publish/git-publish-1.8.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-vcs/git-publish/git-publish-1.8.0.ebuild b/dev-vcs/git-publish/git-publish-1.8.0.ebuild
new file mode 100644
index 000000000000..e88b6924fa56
--- /dev/null
+++ b/dev-vcs/git-publish/git-publish-1.8.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit python-single-r1
+
+DESCRIPTION="Tool for preparing and storing patch revisions as git tag"
+HOMEPAGE="https://github.com/stefanha/git-publish"
+SRC_URI="https://github.com/stefanha/git-publish/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+man"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-vcs/git
+"
+BDEPEND="${PYTHON_DEPS}
+ man? ( dev-lang/perl )
+"
+
+src_prepare() {
+ default
+ python_fix_shebang git-publish
+}
+
+src_compile() {
+ if use man; then
+ pod2man --center "git-publish Documentation" --release "${PV}" \
+ git-publish.pod git-publish.1 || die
+ fi
+}
+
+src_install() {
+ dobin git-publish
+ use man && doman git-publish.1
+ insinto /usr/share/${PN}/hooks
+ doins hooks/pre-publish-send-email.example
+}