summaryrefslogtreecommitdiff
path: root/dev-vcs/git-pimp/git-pimp-0.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-23 07:00:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-23 07:00:28 +0100
commite23cdda4dbb0c83b9e682ab5e916085a35203da5 (patch)
tree5a4ac448a3b288b731c24d947e0ce52df3cab07b /dev-vcs/git-pimp/git-pimp-0.8.ebuild
parent8187a741807f3e9a9e26304973cf18087dcf2560 (diff)
gentoo resync : 23.06.2018
Diffstat (limited to 'dev-vcs/git-pimp/git-pimp-0.8.ebuild')
-rw-r--r--dev-vcs/git-pimp/git-pimp-0.8.ebuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/dev-vcs/git-pimp/git-pimp-0.8.ebuild b/dev-vcs/git-pimp/git-pimp-0.8.ebuild
index 26c6c470830e..900a55ad38e0 100644
--- a/dev-vcs/git-pimp/git-pimp-0.8.ebuild
+++ b/dev-vcs/git-pimp/git-pimp-0.8.ebuild
@@ -1,8 +1,7 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils
+EAPI=6
DESCRIPTION="Code review or pull requests as patch email series"
HOMEPAGE="https://github.com/roman-neuhauser/git-mailz/"
@@ -11,11 +10,11 @@ SRC_URI="http://codex.sigpipe.cz/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
+IUSE="test"
-KEYWORDS="~x86 ~amd64"
-
-DEPEND=""
+KEYWORDS="~amd64 ~x86"
+DEPEND="test? ( dev-util/cram )"
RDEPEND="
dev-vcs/git
app-shells/zsh
@@ -24,5 +23,7 @@ RDEPEND="
"
src_install(){
+ # Do not install in /usr/local
emake PREFIX="${ED}/usr" install
+ einstalldocs
}