summaryrefslogtreecommitdiff
path: root/dev-vcs/git-lfs/git-lfs-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-26 04:30:05 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-26 04:30:05 +0100
commit390bde0d9e0b055c7e87ede2f6b3546ec7da02c7 (patch)
treede2070c20b334e95468095ec8e48d7bfcc15c2eb /dev-vcs/git-lfs/git-lfs-9999.ebuild
parent240b57012ace855bbfd9934b07642416ceeeb5b8 (diff)
gentoo auto-resync : 26:07:2023 - 04:30:05
Diffstat (limited to 'dev-vcs/git-lfs/git-lfs-9999.ebuild')
-rw-r--r--dev-vcs/git-lfs/git-lfs-9999.ebuild36
1 files changed, 26 insertions, 10 deletions
diff --git a/dev-vcs/git-lfs/git-lfs-9999.ebuild b/dev-vcs/git-lfs/git-lfs-9999.ebuild
index 9ca4bf2afe35..7b98fd42b0f3 100644
--- a/dev-vcs/git-lfs/git-lfs-9999.ebuild
+++ b/dev-vcs/git-lfs/git-lfs-9999.ebuild
@@ -1,26 +1,37 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 2017-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
EGO_PN=github.com/git-lfs/git-lfs
+# Update the ID as it's included in each build.
+COMMIT_ID="77deabdf9a18f8a07ecfd3e0f4aa572ffbbab8d4"
+
inherit go-module
DESCRIPTION="Command line extension and specification for managing large files with git"
-HOMEPAGE="https://git-lfs.com/"
+HOMEPAGE="
+ https://git-lfs.com
+ https://github.com/git-lfs/git-lfs
+"
if [[ "${PV}" = 9999* ]]; then
EGIT_REPO_URI="https://${EGO_PN}"
inherit git-r3
else
- SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+ SRC_URI="https://${EGO_PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ # Add the manually vendored tarball.
+ # Compress the tarball with: xz -9kT0 --memlimit-decompress=256M
+ SRC_URI+=" https://files.holgersson.xyz/gentoo/distfiles/golang-pkg-deps/${P}-deps.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
fi
LICENSE="Apache-2.0 BSD BSD-2 BSD-4 ISC MIT"
SLOT="0"
IUSE="doc test"
-BDEPEND="doc? ( app-text/ronn-ng )"
+BDEPEND="
+ doc? ( dev-ruby/asciidoctor )
+"
RDEPEND="dev-vcs/git"
RESTRICT+=" !test? ( test )"
@@ -34,16 +45,22 @@ DOCS=(
)
src_compile() {
+ export CGO_ENABLED=0
+
# Flags -w, -s: Omit debugging information to reduce binary size,
# see https://golang.org/cmd/link/.
local mygobuildargs=(
- -ldflags="-X ${EGO_PN}/config.GitCommit=${GIT_COMMIT} -s -w"
- -mod vendor -v -work -x
+ -ldflags="-X ${EGO_PN}/config.GitCommit=${COMMIT_ID} -s -w"
+ -gcflags=" "
+ -trimpath
+ -v -work -x
)
go build "${mygobuildargs[@]}" -o git-lfs git-lfs.go || die
if use doc; then
- ronn docs/man/*.ronn || die "man building failed"
+ for doc in docs/man/*adoc;
+ do asciidoctor -b manpage ${doc} || die "man building failed"
+ done
fi
}
@@ -55,8 +72,7 @@ src_install() {
src_test() {
local mygotestargs=(
- -ldflags="-X ${EGO_PN}/config.GitCommit=${GIT_COMMIT}"
- -mod vendor
+ -ldflags="-X ${EGO_PN}/config.GitCommit=${COMMIT_ID}"
)
go test "${mygotestargs[@]}" ./... || die
}