summaryrefslogtreecommitdiff
path: root/dev-vcs/git-filter-repo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-03 00:07:26 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-03 00:07:26 +0100
commita3bb28551df94028000fb72308a9e9baa01458b0 (patch)
tree33b14c7bf0dffbd5bb04dbd5b395514ebdda4896 /dev-vcs/git-filter-repo
parent6657c680376cedf378fcf328e5fa03ed3b41d580 (diff)
gentoo auto-resync : 03:06:2024 - 00:07:25
Diffstat (limited to 'dev-vcs/git-filter-repo')
-rw-r--r--dev-vcs/git-filter-repo/Manifest3
-rw-r--r--dev-vcs/git-filter-repo/files/git-filter-repo-2.38.0-new-git.patch30
-rw-r--r--dev-vcs/git-filter-repo/git-filter-repo-2.38.0-r3.ebuild (renamed from dev-vcs/git-filter-repo/git-filter-repo-2.38.0-r2.ebuild)10
3 files changed, 41 insertions, 2 deletions
diff --git a/dev-vcs/git-filter-repo/Manifest b/dev-vcs/git-filter-repo/Manifest
index 446257d1ed08..2c162dd80ea0 100644
--- a/dev-vcs/git-filter-repo/Manifest
+++ b/dev-vcs/git-filter-repo/Manifest
@@ -1,3 +1,4 @@
+AUX git-filter-repo-2.38.0-new-git.patch 1373 BLAKE2B 4c078e9c4fea40054ff4f2c5f6282c2993c5de61c62c80e0fabeb1aaa3e639cad95eb2d8987a63dd6ce1efd0865427a04c22f77dfb6072796605b57aca93d394 SHA512 09d7979141bbe529c898b5e349016a2c810770992f800c064379567006e78f05de2665e6f1e99c3083a83630a313a9c0b5c528e3d628e91a637f88ccbcc1d973
DIST git-filter-repo-2.38.0.tar.xz 153772 BLAKE2B 491269226c5db9fa57bb5e2038e2c8cb3e82577ff1ba8b34920857c2ec4275d4491e8e17f5bd34e63148ae0d6f7bb57ab3d1d36ffecd390579e0fdc773046d71 SHA512 786c27c1952a5e3625c924e71958cfd61d9065d32754a3e957f258767ccb5b147778c5d499eb82c7c1bf36a2f5a50b1cde372ebbc927aeeedbd713e5ab6563d8
-EBUILD git-filter-repo-2.38.0-r2.ebuild 1343 BLAKE2B af7186865e0eed2292234388a5b2a92453d1b92dbe245ef30eee0a8f7c46be6dc11823f061e725d77e69e03da3eaff9cc6259380b1ffa9146fa04665209d6c5f SHA512 b0d2aa30fd0dcb81bc9dad525c0a87ec858cc1d5d338afb83bf72f00d79af5662ae10c7ead429ef5f1adf2937835fa7ef6dbd6e9b5a7355824d976f8e424869c
+EBUILD git-filter-repo-2.38.0-r3.ebuild 1494 BLAKE2B 79203ea21bbdf780a7faa2543b3aec3dd22315c696449d1ac61c735ffcc4289d0b5ef4866fdee45d70f3870d673bcd92d98d56a3118d0d5fdcab06b7e8af8faf SHA512 01ebd5da5bdcd93d6735df2059db107b82a3ed95798833ba8c3c7322ea14202c11962f02efae36cc3916331400a0a0ff3e20b26f830116eb154792b851f8da8e
MISC metadata.xml 332 BLAKE2B 768cfa834a427091d08c837a789a642a1542d9cfc0075426f43f6316e7a405841c2b858aec27d82b7201807d0aa2af759d2daf6a5b3ac86629bbf8a970d5f781 SHA512 9d4e308e7fb88017a68b0e2b6b612c39c805d10fa143824e7e9b7a881f5b7f132e0b77d0c51ffe57cca773cd4439ae31888ef90854ec0801f6d074d37b3a35ee
diff --git a/dev-vcs/git-filter-repo/files/git-filter-repo-2.38.0-new-git.patch b/dev-vcs/git-filter-repo/files/git-filter-repo-2.38.0-new-git.patch
new file mode 100644
index 000000000000..d54c6a7f8223
--- /dev/null
+++ b/dev-vcs/git-filter-repo/files/git-filter-repo-2.38.0-new-git.patch
@@ -0,0 +1,30 @@
+https://github.com/newren/git-filter-repo/issues/523
+https://github.com/newren/git-filter-repo/pull/526
+
+From 1db1650e6e14443a5a8163213434aec5e190f193 Mon Sep 17 00:00:00 2001
+From: Vladimir Petko <vladimir.petko@canonical.com>
+Date: Fri, 8 Dec 2023 15:05:34 +1300
+Subject: [PATCH] support git 2.43
+
+Git 2.43 changes --mark-tags to --[no-]mark-tags and --reencode to --[no-]reencode. Use both options for the detection check.
+
+Signed-off-by: Vladimir Petko <vladimir.petko@canonical.com>
+--- a/git-filter-repo
++++ b/git-filter-repo
+@@ -2067,13 +2067,13 @@ EXAMPLES
+ if b'--anonymize-map' not in output: # pragma: no cover
+ global date_format_permissive
+ date_format_permissive = False
+- if b'--mark-tags' not in output: # pragma: no cover
++ if not any(x in output for x in [b'--mark-tags',b'--[no-]mark-tags']): # pragma: no cover
+ global write_marks
+ write_marks = False
+ if args.state_branch:
+ # We need a version of git-fast-export with --mark-tags
+ raise SystemExit(_("Error: need git >= 2.24.0"))
+- if b'--reencode' not in output: # pragma: no cover
++ if not any(x in output for x in [b'--reencode', b'--[no-]reencode']): # pragma: no cover
+ if args.preserve_commit_encoding:
+ # We need a version of git-fast-export with --reencode
+ raise SystemExit(_("Error: need git >= 2.23.0"))
+
diff --git a/dev-vcs/git-filter-repo/git-filter-repo-2.38.0-r2.ebuild b/dev-vcs/git-filter-repo/git-filter-repo-2.38.0-r3.ebuild
index c54f9866d9bd..fe82886559bc 100644
--- a/dev-vcs/git-filter-repo/git-filter-repo-2.38.0-r2.ebuild
+++ b/dev-vcs/git-filter-repo/git-filter-repo-2.38.0-r3.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1
DESCRIPTION="Quickly rewrite git repository history (filter-branch replacement)"
@@ -27,6 +27,14 @@ BDEPEND="
# requires a valid source of version info, this one is for distros
export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+python_prepare_all() {
+ cd .. || die
+ eapply "${FILESDIR}"/git-filter-repo-2.38.0-new-git.patch
+ cd "${S}" || die
+
+ distutils-r1_python_prepare_all
+}
+
python_test() {
cd .. || die
bash t/run_tests || die