summaryrefslogtreecommitdiff
path: root/dev-vcs/git-deps
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-vcs/git-deps
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-vcs/git-deps')
-rw-r--r--dev-vcs/git-deps/Manifest2
-rw-r--r--dev-vcs/git-deps/git-deps-9999.ebuild47
-rw-r--r--dev-vcs/git-deps/metadata.xml15
3 files changed, 64 insertions, 0 deletions
diff --git a/dev-vcs/git-deps/Manifest b/dev-vcs/git-deps/Manifest
new file mode 100644
index 000000000000..28ff61877288
--- /dev/null
+++ b/dev-vcs/git-deps/Manifest
@@ -0,0 +1,2 @@
+EBUILD git-deps-9999.ebuild 1028 BLAKE2B d8fdc91d0ce0fefe9314243f60b3dfe5965398094f4680893a3d1ed993987da80e880ba97bb2cc3c71963b650790dfb32b8dd9f04b8a0624b18d7e307f308daf SHA512 2e8826945a6840739f83a266e388fd79ced5394a501d322113e80260711cc1b493d1a060d30b21ca9f967a1651cdd1fcb239a6a390e48488b62c69db6f7e655c
+MISC metadata.xml 490 BLAKE2B 12b1fd6d7c20349fe5ed2f76cfec260442479834c1cba9ef26722719ff6ea8b0d760519d8f7a62220e10b90b4e328a93898a61c974ece364736d1ad4a9828e8b SHA512 005daa7d1c3abffad1bda794339947dabfdb097a2abe85a1ea5b85fd962332d788d2903301f2b3442a3f35f5b97eb25d3ddd1add00460108ffc857f57c3fa926
diff --git a/dev-vcs/git-deps/git-deps-9999.ebuild b/dev-vcs/git-deps/git-deps-9999.ebuild
new file mode 100644
index 000000000000..f66f91356572
--- /dev/null
+++ b/dev-vcs/git-deps/git-deps-9999.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGIT_REPO_URI="https://github.com/aspiers/git-deps"
+EGIT_BRANCH=master
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils git-r3 python-single-r1
+
+DESCRIPTION="git commit dependency analysis tool"
+HOMEPAGE="https://github.com/aspiers/git-deps"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/pygit2[${PYTHON_USEDEP}]
+ net-libs/nodejs
+ ${PYTHON_DEPS}
+ "
+DEPEND="${RDEPEND}"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+HTML_DOCS="html/."
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_install() {
+ python_newscript git-deps.py git-deps
+ einstalldocs
+}
+
+pkg_postinst() {
+ elog "Notes regarding the '--serve' option:"
+ elog "Please run 'npm install browserify' once"
+ elog "Copy the html sources:"
+ elog "rsync -av ${EROOT}/usr/share/${PN}/html ~/git-deps-html"
+ elog "cd ~/git-deps-html"
+ elog "npm install"
+ elog "browserify -t coffeeify -d js/git-deps-graph.coffee -o js/bundle.js"
+}
diff --git a/dev-vcs/git-deps/metadata.xml b/dev-vcs/git-deps/metadata.xml
new file mode 100644
index 000000000000..1a9f54bc290b
--- /dev/null
+++ b/dev-vcs/git-deps/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>nicolasbock@gentoo.org</email>
+ <name>Nicolas Bock</name>
+ </maintainer>
+ <longdescription lang="en">
+ git-deps is a tool for performing automatic analysis of dependencies
+ between commits in a git repository.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">aspiers/git-deps</remote-id>
+ </upstream>
+</pkgmetadata>