summaryrefslogtreecommitdiff
path: root/dev-vcs/cvsps/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-vcs/cvsps/files
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-vcs/cvsps/files')
-rw-r--r--dev-vcs/cvsps/files/cvsps-2.1-build.patch18
-rw-r--r--dev-vcs/cvsps/files/cvsps-2.1-solaris.patch131
-rw-r--r--dev-vcs/cvsps/files/cvsps-2.2_beta1-solaris.patch135
-rw-r--r--dev-vcs/cvsps/files/cvsps-3.13-make.patch52
4 files changed, 0 insertions, 336 deletions
diff --git a/dev-vcs/cvsps/files/cvsps-2.1-build.patch b/dev-vcs/cvsps/files/cvsps-2.1-build.patch
deleted file mode 100644
index bcb394d5dd0b..000000000000
--- a/dev-vcs/cvsps/files/cvsps-2.1-build.patch
+++ /dev/null
@@ -1,18 +0,0 @@
---- Makefile.orig 2008-03-24 07:16:47.000000000 -0400
-+++ Makefile 2008-03-24 07:17:18.000000000 -0400
-@@ -3,6 +3,7 @@
- CC?=gcc
- CFLAGS?=-g -O2 -Wall
- CFLAGS+=-I. -DVERSION=\"$(MAJOR).$(MINOR)\"
-+LDLIBS+=-lz
- prefix?=/usr/local
- OBJS=\
- cbtcommon/debug.o\
-@@ -21,7 +22,6 @@
- all: cvsps
-
- cvsps: $(OBJS)
-- $(CC) -o cvsps $(OBJS) -lz
-
- install:
- [ -d $(prefix)/bin ] || mkdir -p $(prefix)/bin
diff --git a/dev-vcs/cvsps/files/cvsps-2.1-solaris.patch b/dev-vcs/cvsps/files/cvsps-2.1-solaris.patch
deleted file mode 100644
index 3e063fd9248b..000000000000
--- a/dev-vcs/cvsps/files/cvsps-2.1-solaris.patch
+++ /dev/null
@@ -1,131 +0,0 @@
-Modified version of
-http://cvs.openpkg.org/fileview?f=openpkg-src/cvsps/cvsps.patch&v=1.13
-
-Index: cache.c
---- cache.c.orig 2008-04-02 03:18:44 +0200
-+++ cache.c 2008-04-02 09:10:25 +0200
-@@ -361,7 +361,7 @@
-
- strcpy(buff, p_buff);
-
-- while ((s = strsep(&p, ";")))
-+ while ((s = my_strsep(&p, ";")))
- {
- char * c = strchr(s, ':');
-
-Index: cvs_direct.c
---- cvs_direct.c.orig 2008-04-02 03:18:44 +0200
-+++ cvs_direct.c 2008-04-02 09:10:25 +0200
-@@ -92,12 +92,12 @@
-
- strcpy_a(root, p_root, PATH_MAX);
-
-- tok = strsep(&p, ":");
-+ tok = my_strsep(&p, ":");
-
- /* if root string looks like :pserver:... then the first token will be empty */
- if (strlen(tok) == 0)
- {
-- char * method = strsep(&p, ":");
-+ char * method = my_strsep(&p, ":");
- if (strcmp(method, "pserver") == 0)
- {
- ctx = open_ctx_pserver(ctx, p);
-@@ -185,14 +185,14 @@
-
- strcpy_a(root, p_root, PATH_MAX);
-
-- tok = strsep(&p, ":");
-+ tok = my_strsep(&p, ":");
- if (strlen(tok) == 0 || !p)
- {
- debug(DEBUG_APPERROR, "parse error on third token");
- goto out_free_err;
- }
-
-- tok2 = strsep(&tok, "@");
-+ tok2 = my_strsep(&tok, "@");
- if (!strlen(tok2) || (!tok || !strlen(tok)))
- {
- debug(DEBUG_APPERROR, "parse error on user@server in pserver");
-@@ -272,7 +272,7 @@
- strcpy_a(root, p_root, PATH_MAX);
-
- /* if there's a ':', it's remote */
-- tok = strsep(&p, ":");
-+ tok = my_strsep(&p, ":");
-
- if (p)
- {
-@@ -281,7 +281,7 @@
- if (!cvs_rsh)
- cvs_rsh = "rsh";
-
-- tok2 = strsep(&tok, "@");
-+ tok2 = my_strsep(&tok, "@");
-
- if (tok)
- snprintf(execcmd, PATH_MAX, "%s -l %s %s %s server", cvs_rsh, tok2, tok, cvs_server);
-@@ -776,7 +776,7 @@
- static int parse_patch_arg(char * arg, char ** str)
- {
- char *tok, *tok2 = "";
-- tok = strsep(str, " ");
-+ tok = my_strsep(str, " ");
- if (!tok)
- return 0;
-
-@@ -796,7 +796,7 @@
- /* see if command wants two args and they're separated by ' ' */
- if (tok[2] == 0 && strchr("BdDFgiorVxYz", tok[1]))
- {
-- tok2 = strsep(str, " ");
-+ tok2 = my_strsep(str, " ");
- if (!tok2)
- {
- debug(DEBUG_APPERROR, "diff_opts parse_error: argument %s requires two arguments", tok);
-Index: util.c
---- util.c.orig 2008-04-02 03:18:44 +0200
-+++ util.c 2008-04-02 09:10:25 +0200
-@@ -316,3 +316,31 @@
- exit(1);
- }
- }
-+
-+char *my_strsep(char **stringp, const char *delim)
-+{
-+ char *s;
-+ const char *spanp;
-+ int c, sc;
-+ char *tok;
-+
-+ if ((s = *stringp) == NULL)
-+ return NULL;
-+ for (tok = s;;) {
-+ c = *s++;
-+ spanp = delim;
-+ do {
-+ if ((sc = *spanp++) == c) {
-+ if (c == 0)
-+ s = NULL;
-+ else
-+ s[-1] = 0;
-+ *stringp = s;
-+ return tok;
-+ }
-+ } while (sc != 0);
-+ }
-+ /* NOTREACHED */
-+ return NULL;
-+}
-+
-Index: util.h
---- util.h.orig 2008-04-02 03:18:44 +0200
-+++ util.h 2008-04-02 09:15:35 +0200
-@@ -24,5 +24,6 @@
- void timing_stop(const char *);
- int my_system(const char *);
- int escape_filename(char *, int, const char *);
-+char *my_strsep(char **, const char *);
-
- #endif /* UTIL_H */
diff --git a/dev-vcs/cvsps/files/cvsps-2.2_beta1-solaris.patch b/dev-vcs/cvsps/files/cvsps-2.2_beta1-solaris.patch
deleted file mode 100644
index 444ac1382a7b..000000000000
--- a/dev-vcs/cvsps/files/cvsps-2.2_beta1-solaris.patch
+++ /dev/null
@@ -1,135 +0,0 @@
-Modified version of.
-http://cvs.openpkg.org/fileview?f=openpkg-src/cvsps/cvsps.patch&v=1.13
-
-diff --git a/cache.c b/cache.c
-index 4c51cf7..2c3918d 100644
---- a/cache.c
-+++ b/cache.c
-@@ -361,7 +361,7 @@ static void parse_cache_revision(PatchSetMember * psm, const char * p_buff)
-
- strcpy(buff, p_buff);
-
-- while ((s = strsep(&p, ";")))
-+ while ((s = my_strsep(&p, ";")))
- {
- char * c = strchr(s, ':');
-
-diff --git a/cvs_direct.c b/cvs_direct.c
-index e281848..5aa8f0f 100644
---- a/cvs_direct.c
-+++ b/cvs_direct.c
-@@ -92,12 +92,12 @@ CvsServerCtx * open_cvs_server(char * p_root, int compress)
-
- strcpy_a(root, p_root, PATH_MAX);
-
-- tok = strsep(&p, ":");
-+ tok = my_strsep(&p, ":");
-
- /* if root string looks like :pserver:... then the first token will be empty */
- if (strlen(tok) == 0)
- {
-- char * method = strsep(&p, ":");
-+ char * method = my_strsep(&p, ":");
- if (strcmp(method, "pserver") == 0)
- {
- ctx = open_ctx_pserver(ctx, p);
-@@ -185,14 +185,14 @@ static CvsServerCtx * open_ctx_pserver(CvsServerCtx * ctx, const char * p_root)
-
- strcpy_a(root, p_root, PATH_MAX);
-
-- tok = strsep(&p, ":");
-+ tok = my_strsep(&p, ":");
- if (strlen(tok) == 0 || !p)
- {
- debug(DEBUG_APPERROR, "parse error on third token");
- goto out_free_err;
- }
-
-- tok2 = strsep(&tok, "@");
-+ tok2 = my_strsep(&tok, "@");
- if (!strlen(tok2) || (!tok || !strlen(tok)))
- {
- debug(DEBUG_APPERROR, "parse error on user@server in pserver");
-@@ -272,7 +272,7 @@ static CvsServerCtx * open_ctx_forked(CvsServerCtx * ctx, const char * p_root)
- strcpy_a(root, p_root, PATH_MAX);
-
- /* if there's a ':', it's remote */
-- tok = strsep(&p, ":");
-+ tok = my_strsep(&p, ":");
-
- if (p)
- {
-@@ -281,7 +281,7 @@ static CvsServerCtx * open_ctx_forked(CvsServerCtx * ctx, const char * p_root)
- if (!cvs_rsh)
- cvs_rsh = "rsh";
-
-- tok2 = strsep(&tok, "@");
-+ tok2 = my_strsep(&tok, "@");
-
- if (tok)
- snprintf(execcmd, PATH_MAX, "%s -l %s %s %s server", cvs_rsh, tok2, tok, cvs_server);
-@@ -776,7 +776,7 @@ void cvs_rupdate(CvsServerCtx * ctx, const char * rep, const char * file, const
- static int parse_patch_arg(char * arg, char ** str)
- {
- char *tok, *tok2 = "";
-- tok = strsep(str, " ");
-+ tok = my_strsep(str, " ");
- if (!tok)
- return 0;
-
-@@ -796,7 +796,7 @@ static int parse_patch_arg(char * arg, char ** str)
- /* see if command wants two args and they're separated by ' ' */
- if (tok[2] == 0 && strchr("BdDFgiorVxYz", tok[1]))
- {
-- tok2 = strsep(str, " ");
-+ tok2 = my_strsep(str, " ");
- if (!tok2)
- {
- debug(DEBUG_APPERROR, "diff_opts parse_error: argument %s requires two arguments", tok);
-diff --git a/util.c b/util.c
-index 7884c84..f3ab3a3 100644
---- a/util.c
-+++ b/util.c
-@@ -316,3 +316,31 @@ void strcpy_a(char * dst, const char * src, int n)
- exit(1);
- }
- }
-+
-+char *my_strsep(char **stringp, const char *delim)
-+{
-+ char *s;
-+ const char *spanp;
-+ int c, sc;
-+ char *tok;
-+
-+ if ((s = *stringp) == NULL)
-+ return NULL;
-+ for (tok = s;;) {
-+ c = *s++;
-+ spanp = delim;
-+ do {
-+ if ((sc = *spanp++) == c) {
-+ if (c == 0)
-+ s = NULL;
-+ else
-+ s[-1] = 0;
-+ *stringp = s;
-+ return tok;
-+ }
-+ } while (sc != 0);
-+ }
-+ /* NOTREACHED */
-+ return NULL;
-+}
-+
-diff --git a/util.h b/util.h
-index ff2d3a0..336fd63 100644
---- a/util.h
-+++ b/util.h
-@@ -24,5 +24,6 @@ void timing_stop(const char *);
- int my_system(const char *);
- int escape_filename(char *, int, const char *);
- void strcpy_a(char * dst, const char * src, int n);
-+char *my_strsep(char **, const char *);
-
- #endif /* UTIL_H */
diff --git a/dev-vcs/cvsps/files/cvsps-3.13-make.patch b/dev-vcs/cvsps/files/cvsps-3.13-make.patch
deleted file mode 100644
index 7c96d60300a1..000000000000
--- a/dev-vcs/cvsps/files/cvsps-3.13-make.patch
+++ /dev/null
@@ -1,52 +0,0 @@
-diff --git a/Makefile b/Makefile
-index 6266c9d..4f60d2f 100644
---- a/Makefile
-+++ b/Makefile
-@@ -8,6 +8,9 @@ INSTALL = install
- prefix?=/usr/local
- target=$(DESTDIR)$(prefix)
-
-+PROG = cvsps
-+MANPAGE = $(PROG).1
-+
- OBJS= debug.o \
- hash.o \
- sio.o \
-@@ -19,12 +22,12 @@ OBJS= debug.o \
- cvsclient.o \
- list_sort.o
-
--all: cvsps
-+all: $(PROG) $(MANPAGE)
-
- deps:
- makedepend -Y -I. *.c
-
--cvsps: $(OBJS)
-- $(CC) -o cvsps $(OBJS) $(LDFLAGS) $(LDLIBS)
-+$(PROG): $(OBJS)
-+ $(CC) -o $(PROG) $(OBJS) $(LDFLAGS) $(LDLIBS)
-
- check:
-@@ -50,17 +53,17 @@ pylint:
- .txt.html:
- a2x --doctype manpage --format xhtml $*.txt
-
--install: cvsps.1 all
-+install: all
- $(INSTALL) -d "$(target)/bin"
- $(INSTALL) -d "$(target)/share/man/man1"
-- $(INSTALL) cvsps "$(target)/bin"
-- $(INSTALL) -m 644 cvsps.1 "$(target)/share/man/man1"
-+ $(INSTALL) $(PROG) "$(target)/bin"
-+ $(INSTALL) -m 644 $(MANPAGE) "$(target)/share/man/man1"
-
- tags: *.c *.h
- ctags *.c *.h
-
- clean:
-- rm -f cvsps *.o core tags cvsps.1 cvsps.html docbook-xsl.css
-+ rm -f $(PROG) *.o core tags $(MANPAGE) cvsps.html docbook-xsl.css
-
- SOURCES = Makefile *.[ch] merge_utils.sh
- DOCS = README COPYING NEWS cvsps.asc TODO