summaryrefslogtreecommitdiff
path: root/dev-util
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-11 23:23:25 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-11 23:23:25 +0000
commit8e95bde8579d855189ccca3e693b4e3792f136c2 (patch)
tree4202dc7a3017eba106e5c5c5a41bcb3d08281143 /dev-util
parent25e5a6599437664a3eff8d9f8a966adc896e09e8 (diff)
gentoo auto-resync : 11:12:2023 - 23:23:25
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/Manifest.gzbin70291 -> 70454 bytes
-rw-r--r--dev-util/runme/Manifest4
-rw-r--r--dev-util/runme/metadata.xml11
-rw-r--r--dev-util/runme/runme-2.0.5.ebuild34
4 files changed, 49 insertions, 0 deletions
diff --git a/dev-util/Manifest.gz b/dev-util/Manifest.gz
index bb3242ab945f..125b4dacbf28 100644
--- a/dev-util/Manifest.gz
+++ b/dev-util/Manifest.gz
Binary files differ
diff --git a/dev-util/runme/Manifest b/dev-util/runme/Manifest
new file mode 100644
index 000000000000..3a29407874c5
--- /dev/null
+++ b/dev-util/runme/Manifest
@@ -0,0 +1,4 @@
+DIST runme-2.0.5-deps.tar.xz 120617272 BLAKE2B 2e01b05a0a2ab0218c69bbbbfe1c1c05021d8a44c0b0ba105becb27d5c44f1518e24618d215c4ea5193a52237a11b70edc05ead7d0923448a0793f8739c62e0b SHA512 b6f61ad651fbe5fea7dff7923e7db8d2ab30bd6ceb3a18254032ce989990806670b94f20b3a0b2cc0e1b29505c75595a25f6dc9e896c318b653c4974f4fad873
+DIST runme-2.0.5.tar.gz 3670340 BLAKE2B 1a39e4f39ce79904e4c74e87f4bfdae4b273ea88635530af827ce48a5284092022803337016f8eff4a2988fdf0b03073436c9b20654ac7bfe39f9e5f303953bc SHA512 c72d7f30d4bf576fac2fb77376cbd4cea2bcc17a8c41208db2f684be36aebf4da03539ecfe0753b3f0b0803e39c7a15b9f2ceb5a40569db6ecd837330ce3def2
+EBUILD runme-2.0.5.ebuild 711 BLAKE2B 02e9bf25402edd3b57ca75f9890334965b8b5fd7aa94d74a18c4038728cbc45c8b9bd4914cd4a10f752a4d339d4956e833258fc4bcdf0a0eb77feba1bc79386c SHA512 13ea28659bd0675e9bbfc20b0bd824a0133338741fde2171bcee8494d60e8b525becb6afe24535941955a60cc1e8c37cf208c0f271c37fb8e23fb4f567692214
+MISC metadata.xml 328 BLAKE2B 67546fdba2d55d996fd1143006f48505f502c01406587b415d2d42cb9dcd89e8c227913bd4d3e9b3dd1e1298950282843a5d52c66276651c532593c601154326 SHA512 0ddc3be61a49bb0d49e387ed97d4a48b7a1f7efd898af585b47d88f1b90048b5e417f8292f9528b295776ec15a2c33ea122df5c0cd8744542bd49e26e50552fe
diff --git a/dev-util/runme/metadata.xml b/dev-util/runme/metadata.xml
new file mode 100644
index 000000000000..36f084a54c06
--- /dev/null
+++ b/dev-util/runme/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>williamh@gentoo.org</email>
+ <name>William Hubbs</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">stateful/runme</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-util/runme/runme-2.0.5.ebuild b/dev-util/runme/runme-2.0.5.ebuild
new file mode 100644
index 000000000000..9af10cc64611
--- /dev/null
+++ b/dev-util/runme/runme-2.0.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+# fix these on every bump
+GIT_SHA=bed11d0ed538857f007c55d2ce70905a94111130
+GIT_SHA_SHORT=bed11d0
+VERSION=v${PV}-${GIT_SHA_SHORT}
+
+DESCRIPTION="Execute your runbooks, docs and READMEs"
+HOMEPAGE="https://runme.dev"
+SRC_URI="https://github.com/stateful/runme/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+unset LDFLAGS
+
+src_compile() {
+ emake \
+ GIT_SHA="${GIT_SHA}" \
+ GIT_SHA_SHORT="${GIT_SHA_SHORT}" \
+ VERSION="${VERSION}"
+}
+
+src_install() {
+ dobin runme
+ einstalldocs
+}