summaryrefslogtreecommitdiff
path: root/dev-util
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-06 18:11:38 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-06 18:11:38 +0000
commit6c0d1528e3598898fd1026a3da35ffede0a1f14a (patch)
treed5ab9d7f6d2b41d05fb156069ee81e9ed779f12b /dev-util
parent29efd7db303b443e103311cc0e458ee5c134e8e5 (diff)
gentoo auto-resync : 06:01:2023 - 18:11:38
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/Manifest.gzbin68419 -> 68413 bytes
-rw-r--r--dev-util/diffoscope/Manifest2
-rw-r--r--dev-util/diffoscope/diffoscope-231.ebuild120
-rw-r--r--dev-util/scons/Manifest2
-rw-r--r--dev-util/scons/scons-4.4.0-r1.ebuild3
5 files changed, 125 insertions, 2 deletions
diff --git a/dev-util/Manifest.gz b/dev-util/Manifest.gz
index d71a660ed9a2..a6107d2fac9a 100644
--- a/dev-util/Manifest.gz
+++ b/dev-util/Manifest.gz
Binary files differ
diff --git a/dev-util/diffoscope/Manifest b/dev-util/diffoscope/Manifest
index 44cef6324be1..62903b14b98b 100644
--- a/dev-util/diffoscope/Manifest
+++ b/dev-util/diffoscope/Manifest
@@ -1,5 +1,7 @@
DIST diffoscope-229.tar.gz 3164192 BLAKE2B bee9fa1561ddcfde98cfa44cd6d66a28c636dbc7f3ec1f4895e91dfd3b66c039b68d53be0528b94c112552069886c3c81de4d9b9bc9038d183afdc9fdde6ddb9 SHA512 825c9c33f3088ba082ea3b998594445987558ee62b8b1fbfcded9b72a739faaa73908f8753b8772b3b1a8a43dbcfd52978265a18bdd92605defcd174884ccb23
DIST diffoscope-230.tar.gz 3164600 BLAKE2B f5ad44ff36d07fc5724895e661e0946b292146d004e97159fef1cb58ff38669702a3990740e4ea34300a9b48aeb10263aeb6bb332da3ec987c355ed5b910fedd SHA512 e025e5f95ae2fb9de466b886c58a44f64e0f654fb049bf9f035209fe7ca1fd0ccc14a382b17085c13bc9f2be0d368482d57a071a577cb87628ae7eb0060158ad
+DIST diffoscope-231.tar.gz 3164686 BLAKE2B 5fe1546f63a047def4d1c9acc94360085be87460de1c106381532d937d1ad16be64749b9021caa7980a61a0dfd822ed7163e0f52bb0cab0520962b84bb184650 SHA512 544510de0790fc8f0c62030bc557f923bad6d5c39b7364e9944ebcf9bc5c1ecf2b9ecc91cf9142e54a23b1f004f53e96ed5b6f2f4637fa76cebd2ed7d0e4721d
EBUILD diffoscope-229.ebuild 3562 BLAKE2B 103db80102cb91b40241f3beb9b51118381ff90041a3a2e9f66356b4a16d088c9d0d76de19cf66dce634e96f3f0cf2337c9c5ada17460ec643c406a5be32d274 SHA512 ce0f6e56a4b9ce0ed00f2db3b0fa2143ffef59e253c321ac476d213f6937102c8af747016c6f8f5195b3b49c26bf12aef70309b725625869c20e6dfd2cfb39c4
EBUILD diffoscope-230.ebuild 3569 BLAKE2B 0f2c90d2ac24f75a70391d46994b148bdc9ee03793cb5548c8fec4acffc507d494b73e9e0d0d77b9128e8087bd4966af9c8c012dd9482304845026831bcb5a0e SHA512 67999a8f3074b144f9b73b99b0b76884fdfdca4afea7c6eb281ed392501289d99bc28c651530a81d2793427de50e24eaccf2fc9a6cfbcb255bd8ed506d15e859
+EBUILD diffoscope-231.ebuild 3568 BLAKE2B 7fd37f690793787c4855071df56e0a6ab88c3aa8d6a7683dc666956165f5830d3eee62f385376acb98f9ff6311fdf48ea5b7686ff670d34fe620936d197417dd SHA512 a6e2a888f506d2f385a6c59ad435398403b85440fd9b89953ac1956de383cffaf4decc6ecfff76ad7f03c90da719fe14bd2869a9726c99c7b0b5e455a33337d5
MISC metadata.xml 2078 BLAKE2B 3bb126836e45e8d4e5b6170a12219ec9cceb1a12dca4658211b1971cb16fa5593622642ade363904cf24df16de0749b957d0fc03838d2a9a004484d0b551c886 SHA512 382cefe0478282000b74e404cdd9d636a0323fceb55b97fd8545190628c319e0c5e213c7d082198e4b8b1fc693a52ce85c52b3ad831778e6fadbe6ba401782f5
diff --git a/dev-util/diffoscope/diffoscope-231.ebuild b/dev-util/diffoscope/diffoscope-231.ebuild
new file mode 100644
index 000000000000..0f8d6d4ddb54
--- /dev/null
+++ b/dev-util/diffoscope/diffoscope-231.ebuild
@@ -0,0 +1,120 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_REQ_USE="ncurses"
+inherit distutils-r1
+
+DESCRIPTION="Will try to get to the bottom of what makes files or directories different"
+HOMEPAGE="https://diffoscope.org/ https://pypi.org/project/diffoscope/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc64 ~x86"
+IUSE="acl binutils bzip2 libcaca colord cpio +diff docx dtc e2fsprogs file
+find gettext gif gpg haskell hdf5 hex imagemagick iso java llvm lzma
+mono opendocument pascal pdf postscript R rpm sqlite squashfs
+ssh tar test tcpdump zip zlib zstd"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/python-magic[${PYTHON_USEDEP}]
+ dev-python/libarchive-c[${PYTHON_USEDEP}]
+ dev-python/distro[${PYTHON_USEDEP}]
+ dev-python/tlsh[${PYTHON_USEDEP}]
+ acl? ( sys-apps/acl )
+ binutils? ( sys-devel/binutils )
+ bzip2? ( app-arch/bzip2 )
+ libcaca? ( media-libs/libcaca )
+ colord? ( x11-misc/colord )
+ cpio? ( app-arch/cpio )
+ diff? ( sys-apps/diffutils )
+ docx? ( app-text/docx2txt )
+ dtc? ( sys-apps/dtc )
+ e2fsprogs? ( sys-fs/e2fsprogs )
+ file? ( sys-apps/file )
+ find? ( sys-apps/findutils )
+ gettext? ( sys-devel/gettext )
+ gif? ( media-libs/giflib )
+ gpg? ( app-crypt/gnupg )
+ haskell? ( dev-lang/ghc )
+ hdf5? ( sci-libs/hdf5 )
+ hex? ( app-editors/vim-core )
+ imagemagick? ( media-gfx/imagemagick )
+ iso? ( app-cdr/cdrtools )
+ java? ( virtual/jdk )
+ llvm? ( sys-devel/llvm )
+ lzma? ( app-arch/xz-utils )
+ mono? ( dev-lang/mono )
+ opendocument? ( app-text/odt2txt )
+ pascal? ( dev-lang/fpc )
+ pdf? (
+ app-text/pdftk
+ app-text/poppler
+ dev-python/pypdf[${PYTHON_USEDEP}]
+ )
+ postscript? ( app-text/ghostscript-gpl )
+ R? ( dev-lang/R )
+ rpm? ( app-arch/rpm )
+ sqlite? ( dev-db/sqlite:3 )
+ squashfs? ( sys-fs/squashfs-tools )
+ ssh? ( net-misc/openssh )
+ tar? ( app-arch/tar )
+ tcpdump? ( net-analyzer/tcpdump )
+ zip? ( app-arch/unzip )
+ zlib? ( app-arch/gzip )
+ zstd? ( app-arch/zstd )
+"
+# Presence of filemagic's magic.py breaks imports
+# of dev-python/python-magic: bug #716482
+RDEPEND+=" !dev-python/filemagic"
+
+# pull in optional tools for tests:
+# img2txt: bug #797688
+# docx2txt: bug #797688
+BDEPEND="
+ test? (
+ app-text/docx2txt
+ app-text/html2text
+ media-libs/libcaca
+ virtual/imagemagick-tools[jpeg]
+ )
+"
+
+EPYTEST_DESELECT=(
+ # Test seems to use different tarball
+ tests/test_presenters.py::test_text_proper_indentation
+
+ # Needs triage
+ tests/comparators/test_binary.py::test_with_compare_details_and_tool_not_found
+ tests/comparators/test_rlib.py::test_item3_deflate_llvm_bitcode
+ tests/comparators/test_gif.py::test_has_visuals
+
+ # img2txt based failures, bug #797688
+ tests/comparators/test_ico_image.py::test_diff
+ tests/comparators/test_ico_image.py::test_diff_meta
+ tests/comparators/test_ico_image.py::test_diff_meta2
+ tests/comparators/test_ico_image.py::test_has_visuals
+ tests/comparators/test_jpeg_image.py::test_diff
+ tests/comparators/test_jpeg_image.py::test_compare_non_existing
+ tests/comparators/test_jpeg_image.py::test_diff_meta
+ tests/comparators/test_jpeg_image.py::test_has_visuals
+
+ # docx2txt based falures, bug #797688
+ tests/comparators/test_docx.py::test_diff
+
+ # Formatting
+ tests/test_source.py::test_code_is_black_clean
+
+ # Fails on ZFS
+ tests/test_main.py::test_non_unicode_filename
+
+ # Fails on (unreleased) LLVM 16 with minor difference
+ tests/comparators/test_macho.py::test_llvm_diff
+)
+
+distutils_enable_tests pytest
diff --git a/dev-util/scons/Manifest b/dev-util/scons/Manifest
index b0e3252b2fb3..c8e66052faaf 100644
--- a/dev-util/scons/Manifest
+++ b/dev-util/scons/Manifest
@@ -4,6 +4,6 @@ DIST SCons-4.4.0.tar.gz 3096863 BLAKE2B 60f125c077dd8f50a7150db6dc1234eac988cf7e
DIST scons-4.4.0-user.html 1608381 BLAKE2B ff4eb1e0f9c5e8ea7ca44cc00dc37e3e2dd38c24cb09a857c691e6a48f11e5fc86a55740037cc295e6b23df2a1c1b600adf0462320ec87cc26d4bcf919b07342 SHA512 8c1d6578270054efba34c56ddc07b4314bf62630f6a445f5b9f865cc48d593f6c92101a8d216dece201b8d6cb5bce59ff4adb51caaa40128e96b6235087f748c
DIST scons-4.4.0-user.pdf 2964111 BLAKE2B 45b37c99c3f3d0e9969a16506e27aeabfd562155405f5a59ba79c24404b14e5588fbd0673d86e2266adbd25eca140c9e1cf86e271228658591c0d9285474f078 SHA512 57330f685e7c775cb1c782e40f711c2b2322fad19212a22a920aff92db974610cc78f276e1606fb827660bb488ce803e2458bb9d93c452fa0600df4478f03d06
DIST scons-4.4.0.gh.tar.gz 5808265 BLAKE2B f6ce757f2edc40551b05285098626bb62def6abda2380d4885ee4443868e715e53aaa34f26c09dc689bb6ade26d1b0e276046fe3b1d2ddf8eb40400bca9ea164 SHA512 01fcd40bf818ca22a278973af1cda3024efb74cf877f15d46607fda860448fbd577fc96ba33fef2bed3d145e662a0371f55e8c927e7ac44feea7f3081791ce11
-EBUILD scons-4.4.0-r1.ebuild 3747 BLAKE2B 284dd9ccb9b95cd700ff8cbe8c3f5ec67cf184f620e3cf8d807243f787c102c7dd4fde5fc6ae712aa435cc1072633512d309c4d7fedab55346e62b363a2af8b3 SHA512 0d1fab7a968c9afd6d5a3970f9405af2a0ba05bf4e2d5d5f1703c92f807f79ebb8d034e7626acce91d5bee8d275f5a88a1139872968a41911f314243388333dd
+EBUILD scons-4.4.0-r1.ebuild 3785 BLAKE2B 5032b5dec06dc231fa0f2824f82c01c23ab91305abbd88db8adb9bcc7122862df92f7a9f1fd61b45406fb6622ce49a97bdf2aa0cc2cb93d97abd694ff8266da5 SHA512 1ae0ae8562bbea9c29f97736efd3bcd07a57bd9f4e48baa32a191fd293e952bdaee68d6b96c7b884fc4b78ae6f3c19bae428a5892e3c9c193ec405cd419dbd1c
EBUILD scons-4.4.0.ebuild 3659 BLAKE2B 173ff394924798fd1f47bcb577d8598a99b4b293431152d4681e98cb2448d42b12b90d7227a956ddb2448d206b553f06eff998c4ee25b4c2f7c8075085801836 SHA512 15e5c9b00a1538beed25e61308a695325ef7f85565bb1679cd8b7dd3c4dcaa974489e4ebe1463b4b5c784d596fd7755bf38b9bafbd3e8929bdbaa3db496c8ab4
MISC metadata.xml 803 BLAKE2B 17a1596fb7b6991a9c4732c8e8c1231cd57ba42ae9e0b65a475f4a00503bacba23ae671df112909688574f836962951dcd2fd7a35bc83c34a0eeb72ecb96bbc2 SHA512 c1451442bdf49d7c85cc84831ea3a8a540581680858dc1ac117080b6a8558419d004952ade0410c0b31d9d241ae3d5eef1c81525ecb80c40cdc380b50f49e1ad
diff --git a/dev-util/scons/scons-4.4.0-r1.ebuild b/dev-util/scons/scons-4.4.0-r1.ebuild
index a6021628266f..b6372ae52a96 100644
--- a/dev-util/scons/scons-4.4.0-r1.ebuild
+++ b/dev-util/scons/scons-4.4.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -41,6 +41,7 @@ BDEPEND="
test? (
dev-libs/libxml2[${PYTHON_USEDEP}]
dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
)
"