summaryrefslogtreecommitdiff
path: root/dev-util/xesam-tools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-util/xesam-tools
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-util/xesam-tools')
-rw-r--r--dev-util/xesam-tools/Manifest3
-rw-r--r--dev-util/xesam-tools/metadata.xml10
-rw-r--r--dev-util/xesam-tools/xesam-tools-0.7.0-r1.ebuild42
3 files changed, 55 insertions, 0 deletions
diff --git a/dev-util/xesam-tools/Manifest b/dev-util/xesam-tools/Manifest
new file mode 100644
index 000000000000..27a10b045b10
--- /dev/null
+++ b/dev-util/xesam-tools/Manifest
@@ -0,0 +1,3 @@
+DIST xesam-tools-0.7.0.tar.gz 73173 BLAKE2B f1d8f69d18bd72db4ca40131be8c2e9eac8752d18d8958e343e0c6dd5e49b7a6d89399aec4e4306d2f3c35fddbf4530deff4f9fd09ed0c47b2cc59694ff6baec SHA512 3428e18eb52fa205bca872c8b0b1f12f01f58a8fb43239bc2cc78fe52f9903940702dae4116d4775340b69ec949ad2198b57c0c1246fe58dd8ed8b7a6562bf71
+EBUILD xesam-tools-0.7.0-r1.ebuild 882 BLAKE2B 25d449d3fcdaa598d46480b6cb4d297de08bf89a6af925b604cae89735dc45e6a6100d0b7da10c9785611e2032733a36fc115f2c1d838cce85cb9d4ed0d964d8 SHA512 ed796ebb4d4698fe04c6f8d5b88a969238018789fa1a7088900ea6856ec68b27b83f0e3d502911aed45113cc21de624e051fe52824ab264e24ff2c816ced849e
+MISC metadata.xml 392 BLAKE2B 3ae2a8f256053d6fa0322ea781210ecc3e225bb0eb67e53edfca71a6dc57fb8e5bd283a1b839f25f8bc3bfaf526a88acc4f1d8c83a8cfabc5a90d0883a995a61 SHA512 10e2dafc4fdaa7f851db74280e47df4f37885d2919383d15f9d51004858d3221178052d55c6fe53fcab101389c1ed028c1d9c4e7ca72360c4620c563ae2a7cdf
diff --git a/dev-util/xesam-tools/metadata.xml b/dev-util/xesam-tools/metadata.xml
new file mode 100644
index 000000000000..9c8fd938d1b4
--- /dev/null
+++ b/dev-util/xesam-tools/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <longdescription lang="en">
+ xesam-tools provides a set of tools and examples to help developers
+ who are working on servers or clients which implement the Xesam desktop
+ search specification
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-util/xesam-tools/xesam-tools-0.7.0-r1.ebuild b/dev-util/xesam-tools/xesam-tools-0.7.0-r1.ebuild
new file mode 100644
index 000000000000..c3a780d7fb7e
--- /dev/null
+++ b/dev-util/xesam-tools/xesam-tools-0.7.0-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="xml"
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1
+
+DESCRIPTION="Development tools and examples for the Xesam desktop search API"
+HOMEPAGE="http://xesam.org/people/kamstrup/xesam-tools"
+SRC_URI="http://xesam.org/people/kamstrup/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="examples"
+
+DEPEND=""
+RDEPEND="dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pygobject:2[${PYTHON_USEDEP}]
+ dev-python/pygtk[${PYTHON_USEDEP}]"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ insinto "/usr/share/doc/${PF}"
+ doins -r samples
+
+ if use examples; then
+ insinto "/usr/share/doc/${PF}/demo"
+ doins "demo/demo.py"
+ insopts -m 0755
+ doins demo/[^d]*
+ fi
+}