summaryrefslogtreecommitdiff
path: root/dev-util/xesam-tools/xesam-tools-0.7.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-util/xesam-tools/xesam-tools-0.7.0-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-util/xesam-tools/xesam-tools-0.7.0-r1.ebuild')
-rw-r--r--dev-util/xesam-tools/xesam-tools-0.7.0-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-util/xesam-tools/xesam-tools-0.7.0-r1.ebuild b/dev-util/xesam-tools/xesam-tools-0.7.0-r1.ebuild
new file mode 100644
index 000000000000..c3a780d7fb7e
--- /dev/null
+++ b/dev-util/xesam-tools/xesam-tools-0.7.0-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="xml"
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1
+
+DESCRIPTION="Development tools and examples for the Xesam desktop search API"
+HOMEPAGE="http://xesam.org/people/kamstrup/xesam-tools"
+SRC_URI="http://xesam.org/people/kamstrup/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="examples"
+
+DEPEND=""
+RDEPEND="dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pygobject:2[${PYTHON_USEDEP}]
+ dev-python/pygtk[${PYTHON_USEDEP}]"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ insinto "/usr/share/doc/${PF}"
+ doins -r samples
+
+ if use examples; then
+ insinto "/usr/share/doc/${PF}/demo"
+ doins "demo/demo.py"
+ insopts -m 0755
+ doins demo/[^d]*
+ fi
+}