summaryrefslogtreecommitdiff
path: root/dev-util/xdelta/xdelta-1.1.4-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-10-13 22:19:36 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-10-14 23:22:23 +0100
commit4b19be30aa626b327c885dae62c559ec0e9fb935 (patch)
tree76e74807bc479502e13866b581b6bf86734ec634 /dev-util/xdelta/xdelta-1.1.4-r2.ebuild
parent30d6f67c98d149508509d5e86f176d558793acc0 (diff)
gentoo resync : 13.10.2019
Diffstat (limited to 'dev-util/xdelta/xdelta-1.1.4-r2.ebuild')
-rw-r--r--dev-util/xdelta/xdelta-1.1.4-r2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-util/xdelta/xdelta-1.1.4-r2.ebuild b/dev-util/xdelta/xdelta-1.1.4-r2.ebuild
new file mode 100644
index 000000000000..008f5b44ef68
--- /dev/null
+++ b/dev-util/xdelta/xdelta-1.1.4-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="Computes changes between binary or text files and creates deltas"
+HOMEPAGE="https://xdelta.googlecode.com/"
+SRC_URI="https://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2
+ >=sys-libs/zlib-1.1.4:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ eapply_user
+ eapply "${FILESDIR}"/${P}-m4.patch
+ eapply "${FILESDIR}"/${P}-glib2.patch
+ eapply "${FILESDIR}"/${P}-pkgconfig.patch
+
+ eautoreconf
+}
+
+src_configure() {
+ tc-export CC
+ default
+}