summaryrefslogtreecommitdiff
path: root/dev-util/xdelta/xdelta-1.1.4-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-util/xdelta/xdelta-1.1.4-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-util/xdelta/xdelta-1.1.4-r1.ebuild')
-rw-r--r--dev-util/xdelta/xdelta-1.1.4-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-util/xdelta/xdelta-1.1.4-r1.ebuild b/dev-util/xdelta/xdelta-1.1.4-r1.ebuild
new file mode 100644
index 000000000000..c28337de165e
--- /dev/null
+++ b/dev-util/xdelta/xdelta-1.1.4-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=0
+
+inherit autotools eutils toolchain-funcs
+
+DESCRIPTION="Computes changes between binary or text files and creates deltas"
+HOMEPAGE="https://xdelta.googlecode.com/"
+SRC_URI="https://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2
+ >=sys-libs/zlib-1.1.4"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-m4.patch
+ epatch "${FILESDIR}"/${P}-glib2.patch
+ epatch "${FILESDIR}"/${P}-pkgconfig.patch
+
+ eautoreconf
+}
+
+src_compile() {
+ tc-export CC
+ econf || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README
+}