summaryrefslogtreecommitdiff
path: root/dev-util/wasm3
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-05 17:43:10 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-05 17:43:10 +0000
commitc31f575f39c1e387f18f630fb01d3a89c2339fdf (patch)
treed6db6ce35cd0849abe99eccd07d0f86a1aa82025 /dev-util/wasm3
parent34d05d15811bd789a5348824d4f4151a49f924c9 (diff)
gentoo auto-resync : 05:02:2024 - 17:43:10
Diffstat (limited to 'dev-util/wasm3')
-rw-r--r--dev-util/wasm3/Manifest3
-rw-r--r--dev-util/wasm3/metadata.xml13
-rw-r--r--dev-util/wasm3/wasm3-0.5.0.ebuild39
3 files changed, 55 insertions, 0 deletions
diff --git a/dev-util/wasm3/Manifest b/dev-util/wasm3/Manifest
new file mode 100644
index 000000000000..dc492dde4a6a
--- /dev/null
+++ b/dev-util/wasm3/Manifest
@@ -0,0 +1,3 @@
+DIST wasm3-0.5.0.tar.gz 2582080 BLAKE2B 5ae9fd2aa295cec6a737fa6a56f35ce85a5443dc7b517b019a14bfc30110f3eec7a2421c31905c980694e5017ec6852450c7773e92d4f67fd7af4d41f1de84ed SHA512 87d29f942ef9a93faeb4085f1fc7ae8c274a7bd528ccaaf56a273815c524e43c96635acd6b59ee607d5d0c383c1d1358d09080a0d1a23cf1dcaedcab6c56d39e
+EBUILD wasm3-0.5.0.ebuild 683 BLAKE2B 09798308c95c74b84655405fb666bff246b2c5a8e12bccd4a2cdc0e62f098a660f22b04ca7e058715c678df4e3bfac79674d7180b8d8032dadc779cb2ca045a5 SHA512 f84094e9bf7196b8fd7175c66fcf28738010ceeeebc4d55ff234a8bdf5544b226f3f1a291ca00a53383673897acc49fc0b3fd9c668f1846b27595dcb3b63697c
+MISC metadata.xml 393 BLAKE2B b284a1ec06678e231b2f2c1ee7125d759631218675a09be49616a124a07d1d4a830ecd9019ed92c7b820044af29a08a3b981d6b75ce5be205d34504e69005194 SHA512 fff27354194207d407bc3124e82694ce1786cfb48f433a1dddd88bf906b556f06e64b032f3c716c946618d916973a867a455d101e8de604339dde6808efc9c5c
diff --git a/dev-util/wasm3/metadata.xml b/dev-util/wasm3/metadata.xml
new file mode 100644
index 000000000000..30cd34ad07ab
--- /dev/null
+++ b/dev-util/wasm3/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/wasm3/wasm3/issues/</bugs-to>
+ <remote-id type="github">wasm3/wasm3</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-util/wasm3/wasm3-0.5.0.ebuild b/dev-util/wasm3/wasm3-0.5.0.ebuild
new file mode 100644
index 000000000000..316033c51925
--- /dev/null
+++ b/dev-util/wasm3/wasm3-0.5.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="A fast WebAssembly interpreter and the most universal WASM runtime"
+HOMEPAGE="https://github.com/wasm3/wasm3/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+DOCS=( README.md docs )
+
+src_configure() {
+ local -a mycmakeargs=(
+ -DBUILD_WASI=simple
+ )
+
+ cmake_src_configure
+}
+
+src_install() {
+ dobin "${BUILD_DIR}/wasm3"
+
+ einstalldocs
+}