summaryrefslogtreecommitdiff
path: root/dev-util/wasm3/wasm3-0.5.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-05 17:43:10 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-05 17:43:10 +0000
commitc31f575f39c1e387f18f630fb01d3a89c2339fdf (patch)
treed6db6ce35cd0849abe99eccd07d0f86a1aa82025 /dev-util/wasm3/wasm3-0.5.0.ebuild
parent34d05d15811bd789a5348824d4f4151a49f924c9 (diff)
gentoo auto-resync : 05:02:2024 - 17:43:10
Diffstat (limited to 'dev-util/wasm3/wasm3-0.5.0.ebuild')
-rw-r--r--dev-util/wasm3/wasm3-0.5.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-util/wasm3/wasm3-0.5.0.ebuild b/dev-util/wasm3/wasm3-0.5.0.ebuild
new file mode 100644
index 000000000000..316033c51925
--- /dev/null
+++ b/dev-util/wasm3/wasm3-0.5.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="A fast WebAssembly interpreter and the most universal WASM runtime"
+HOMEPAGE="https://github.com/wasm3/wasm3/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+DOCS=( README.md docs )
+
+src_configure() {
+ local -a mycmakeargs=(
+ -DBUILD_WASI=simple
+ )
+
+ cmake_src_configure
+}
+
+src_install() {
+ dobin "${BUILD_DIR}/wasm3"
+
+ einstalldocs
+}