summaryrefslogtreecommitdiff
path: root/dev-util/visual-regexp/visual-regexp-3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-util/visual-regexp/visual-regexp-3.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-util/visual-regexp/visual-regexp-3.1.ebuild')
-rw-r--r--dev-util/visual-regexp/visual-regexp-3.1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-util/visual-regexp/visual-regexp-3.1.ebuild b/dev-util/visual-regexp/visual-regexp-3.1.ebuild
new file mode 100644
index 000000000000..3920d2a42ab5
--- /dev/null
+++ b/dev-util/visual-regexp/visual-regexp-3.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Type the regexp and visualize it on a sample of your choice"
+HOMEPAGE="http://laurent.riesterer.free.fr/regexp/"
+SRC_URI="
+ https://dev.gentoo.org/~jlec/distfiles/visualregexp-icon.png.tar
+ http://laurent.riesterer.free.fr/regexp/visual_regexp-${PV}.tcl"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=dev-lang/tk-8.5"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ # Manually copy the source file since unpack gets confused by things it can't unpack
+ cp "${DISTDIR}/visual_regexp-${PV}.tcl" "${WORKDIR}/visual_regexp.tcl"
+
+ default
+}
+
+src_prepare() {
+ # File comes with DOS newlines
+ edos2unix visual_regexp.tcl
+
+ epatch \
+ "${FILESDIR}/${P}-wish-fix.patch" \
+ "${FILESDIR}/${P}-help-font-fix.patch" \
+ "${FILESDIR}/${P}-make-regexp-fix.patch" \
+ "${FILESDIR}/${PN}-3.0-home-conf-fix.patch" \
+ "${FILESDIR}/${PN}-3.0-pattern-load-fix.patch"
+
+ epatch_user
+}
+
+src_install() {
+ newbin visual_regexp.tcl visualregexp
+ dosym visualregexp /usr/bin/tkregexp
+ doicon "${WORKDIR}/visualregexp-icon.png"
+ domenu "${FILESDIR}/visualregexp.desktop"
+}