summaryrefslogtreecommitdiff
path: root/dev-util/valgrind/valgrind-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-23 06:54:34 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-23 06:54:34 +0000
commit9a1d1c6b10a4640cea10e7040ed173cf593f4cab (patch)
tree10b7aaa9608311a4b8a7561c6a8da3003ebb061d /dev-util/valgrind/valgrind-9999.ebuild
parentdefbebad0d311b0ce0694b17989a9f26cf000250 (diff)
gentoo auto-resync : 23:01:2023 - 06:54:34
Diffstat (limited to 'dev-util/valgrind/valgrind-9999.ebuild')
-rw-r--r--dev-util/valgrind/valgrind-9999.ebuild16
1 files changed, 10 insertions, 6 deletions
diff --git a/dev-util/valgrind/valgrind-9999.ebuild b/dev-util/valgrind/valgrind-9999.ebuild
index aed73f6be21b..b690f11f1222 100644
--- a/dev-util/valgrind/valgrind-9999.ebuild
+++ b/dev-util/valgrind/valgrind-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -35,10 +35,11 @@ src_prepare() {
# Don't force multiarch stuff on OSX, bug #306467
sed -i -e 's:-arch \(i386\|x86_64\)::g' Makefile.all.am || die
- # Conditionally copy musl specific suppressions && apply patch
if use elibc_musl ; then
- cp "${FILESDIR}/musl.supp" "${S}" || die
- PATCHES+=( "${FILESDIR}"/valgrind-3.13.0-malloc.patch )
+ PATCHES+=(
+ "${FILESDIR}"/${PN}-3.13.0-malloc.patch
+ "${FILESDIR}"/${PN}-3.20.0-musl-interpose.patch
+ )
fi
if [[ ${CHOST} == *-solaris* ]] ; then
@@ -108,6 +109,9 @@ src_install() {
pax-mark m "${ED}"/usr/$(get_libdir)/valgrind/*-*-linux
+ # See README_PACKAGERS
+ dostrip -x /usr/libexec/valgrind/vgpreload* /usr/$(get_libdir)/valgrind/*
+
if [[ ${CHOST} == *-darwin* ]] ; then
# fix install_names on shared libraries, can't turn them into bundles,
# as dyld won't load them any more then, bug #306467
@@ -119,9 +123,9 @@ src_install() {
}
pkg_postinst() {
- elog "Valgrind will not work if glibc does not have debug symbols."
+ elog "Valgrind will not work if libc (e.g. glibc) does not have debug symbols."
elog "To fix this you can add splitdebug to FEATURES in make.conf"
- elog "and remerge glibc. See:"
+ elog "and remerge glibc. See:"
elog "https://bugs.gentoo.org/show_bug.cgi?id=214065"
elog "https://bugs.gentoo.org/show_bug.cgi?id=274771"
elog "https://bugs.gentoo.org/show_bug.cgi?id=388703"