summaryrefslogtreecommitdiff
path: root/dev-util/uncrustify/uncrustify-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-util/uncrustify/uncrustify-9999.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-util/uncrustify/uncrustify-9999.ebuild')
-rw-r--r--dev-util/uncrustify/uncrustify-9999.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-util/uncrustify/uncrustify-9999.ebuild b/dev-util/uncrustify/uncrustify-9999.ebuild
new file mode 100644
index 000000000000..d0891fcae6c3
--- /dev/null
+++ b/dev-util/uncrustify/uncrustify-9999.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ $PV == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
+ KEYWORDS=""
+ SRC_URI=""
+ scm_eclass=git-r3
+else
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x64-solaris ~x86-solaris"
+ SRC_URI="https://github.com/${PN}/${PN}/archive/${P}.tar.gz"
+ S=${WORKDIR}/${PN}-${P}
+fi
+
+inherit cmake-utils ${scm_eclass}
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-any-r1
+
+DESCRIPTION="C/C++/C#/D/Java/Pawn code indenter and beautifier"
+HOMEPAGE="http://uncrustify.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="test"
+
+DEPEND="test? ( ${PYTHON_DEPS} )"
+
+python_test() {
+ cd tests
+ ${EPYTHON} run_tests.py || die "tests failed"
+}