summaryrefslogtreecommitdiff
path: root/dev-util/uncrustify/uncrustify-0.78.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-27 00:57:29 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-27 00:57:29 +0000
commited0a1596c807e379a19960170c94735aff22fa84 (patch)
tree6b57799936730fbd284c7e2bdefe43eafb822976 /dev-util/uncrustify/uncrustify-0.78.1.ebuild
parentdd8cf418a044466cd5a1239059d5d21744f73f14 (diff)
gentoo auto-resync : 27:01:2024 - 00:57:29
Diffstat (limited to 'dev-util/uncrustify/uncrustify-0.78.1.ebuild')
-rw-r--r--dev-util/uncrustify/uncrustify-0.78.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-util/uncrustify/uncrustify-0.78.1.ebuild b/dev-util/uncrustify/uncrustify-0.78.1.ebuild
new file mode 100644
index 000000000000..5b681b1ddc92
--- /dev/null
+++ b/dev-util/uncrustify/uncrustify-0.78.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
+ scm_eclass=git-r3
+else
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+ SRC_URI="https://github.com/${PN}/${PN}/archive/${P}.tar.gz"
+ S=${WORKDIR}/${PN}-${P}
+fi
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit cmake python-any-r1 ${scm_eclass}
+
+DESCRIPTION="C/C++/C#/D/Java/Pawn code indenter and beautifier"
+HOMEPAGE="http://uncrustify.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( ${PYTHON_DEPS} )"
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}