summaryrefslogtreecommitdiff
path: root/dev-util/trinity/trinity-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
commitb7ebc951da8800f711142f69d9d958bde67a112d (patch)
treee318514216845acb8f2e49fff7a5cba4027e9d91 /dev-util/trinity/trinity-9999.ebuild
parentdc7cbdfa65fd814b3b9aa3c56257da201109e807 (diff)
gentoo resync : 28.04.2019
Diffstat (limited to 'dev-util/trinity/trinity-9999.ebuild')
-rw-r--r--dev-util/trinity/trinity-9999.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/dev-util/trinity/trinity-9999.ebuild b/dev-util/trinity/trinity-9999.ebuild
index 4245b613481a..3910c2f87cdd 100644
--- a/dev-util/trinity/trinity-9999.ebuild
+++ b/dev-util/trinity/trinity-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -13,11 +13,15 @@ LICENSE="GPL-2"
SLOT="0"
IUSE="examples"
-DEPEND="sys-kernel/linux-headers"
+# We need newer headers to avoid compilation failures in the BPF stuff.
+DEPEND="
+ >=sys-kernel/linux-headers-4.8
+"
src_prepare() {
sed -e 's/-g -O2//' \
-e 's/-D_FORTIFY_SOURCE=2//' \
+ -e 's/-Werror//' \
-e '/-o $@/s/$(LDFLAGS) //' \
-i Makefile || die
@@ -32,6 +36,7 @@ src_compile() {
src_install() {
dobin ${PN}
dodoc Documentation/* README
+ doman trinity.1
if use examples ; then
exeinto /usr/share/doc/${PF}/scripts