summaryrefslogtreecommitdiff
path: root/dev-util/tea/tea-0.9.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-30 17:04:14 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-30 17:04:14 +0000
commitb34c45ec12e8676abfa39cddcf3448ac2bee1574 (patch)
tree9587fa672dfdc5a5f761d15c9689d2aca8d521b0 /dev-util/tea/tea-0.9.2-r1.ebuild
parent18a69c52453e0db481bfa441cf1d9616c97c9928 (diff)
gentoo auto-resync : 30:11:2023 - 17:04:14
Diffstat (limited to 'dev-util/tea/tea-0.9.2-r1.ebuild')
-rw-r--r--dev-util/tea/tea-0.9.2-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-util/tea/tea-0.9.2-r1.ebuild b/dev-util/tea/tea-0.9.2-r1.ebuild
new file mode 100644
index 000000000000..d63409b1bf24
--- /dev/null
+++ b/dev-util/tea/tea-0.9.2-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1 go-module
+
+DESCRIPTION="Command line tool to interact with Gitea server"
+HOMEPAGE="https://gitea.com/gitea/tea/"
+SRC_URI="
+ https://gitea.com/gitea/tea/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz
+ https://dev.gentoo.org/~xgqt/distfiles/deps/${P}-deps.tar.xz
+"
+S="${WORKDIR}/tea"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test"
+
+# bug #917587
+RDEPEND="!<app-editors/tea-62.1.1"
+
+DOCS=( CHANGELOG.md README.md )
+
+src_compile() {
+ ego build
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe tea
+
+ newbashcomp contrib/autocomplete.sh tea
+
+ einstalldocs
+}