summaryrefslogtreecommitdiff
path: root/dev-util/systemtap
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-27 22:00:51 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-27 22:00:51 +0100
commit14fff03b5545ac6b6f575afd2e6174afbd294fdd (patch)
tree21be5aee55de4f6216e406157ad8c59a811ea202 /dev-util/systemtap
parent9f51c386724b9543e88a9c0e1be57d44326f3116 (diff)
gentoo auto-resync : 27:08:2023 - 22:00:51
Diffstat (limited to 'dev-util/systemtap')
-rw-r--r--dev-util/systemtap/Manifest2
-rw-r--r--dev-util/systemtap/systemtap-4.9.ebuild127
2 files changed, 129 insertions, 0 deletions
diff --git a/dev-util/systemtap/Manifest b/dev-util/systemtap/Manifest
index 699f69314376..ce49d7cba3cc 100644
--- a/dev-util/systemtap/Manifest
+++ b/dev-util/systemtap/Manifest
@@ -1,4 +1,6 @@
AUX systemtap-3.1-ia64.patch 885 BLAKE2B e26c60e4549f95f0db3e128cd535f923f03dc45e0e4ff4049d6b8d6cf44375f88c752a0130e4229a5ccf83a414db8f91504f4ef828d3a7d3d94a5eee78a9e90f SHA512 a9f068dafc2fb4c96696d8cfe1501fc3610f4ab0aaea9a20ffc5f57cda09561f9712896616c548661bbbc5c10dfe275d218c7b232645a5240507c80bec1850cd
DIST systemtap-4.8.tar.gz 5628003 BLAKE2B 9f5050eba29d390c907b117187f94ef088f16bb739b4971bc32ffe88b1024a4157cd4e9793a8fc1e149a5a182a28330e3b4fd9d51213bb3637d616fbb9867f6d SHA512 fdcbc48ba17b2155c1419d99147a4cfbee2e69db945bfd0e6881b71ab11165bd23ea7ce9456856ae36807fb18f9934880a6b7c44456b63833ea260038744d9f2
+DIST systemtap-4.9.tar.gz 6684228 BLAKE2B 880747bcfbaa1909ca20a6cb30eb37d9443547783489396355b642758054ae0e0bf5b495a0adf57851c7c7a6b4300e498bb8c1c8da6df83ab1d1e18877b108a7 SHA512 a2736223fee0c801c36719a0245f31ed7e2e63c30bb7d5cab631dd57e4eb10e04abf2c9b272bda2a17c207c9dd163a1eb8a3e0759eda0c781946e644625510b7
EBUILD systemtap-4.8.ebuild 3280 BLAKE2B 3df1b7041908984eb23fa9a61e6a3dc97a56316797987cd619834d5c66b0e0e8b9046730d804e1e1077f3738939f4c8fa1ae65b26b0e36a3eb9e6cd6c651eb1a SHA512 9eaac26fe33c19d5f6adcdf3f4b6be4b71707d1205a8e0ff087315c7c6767d84332065f5ec735947d787ba3e8be22aaab071dd95bb3e189724cd42e024dbc364
+EBUILD systemtap-4.9.ebuild 3287 BLAKE2B 77c28bd7d076af392879947156eeeafbce4e709b78674796c16fd55778da7f082645688f1f4f0a9b93db6cb1b3df71027aad515930a26e82a3c0556a4e83d2f4 SHA512 b887f3edfcfb6b4b73e1daf6c39c8bbb8b019a94e44057ae724f689bae42d6c791b9591b0b2e8616fbf10c68363a446ecff7402ffc726c1439eed5da949c1ef2
MISC metadata.xml 303 BLAKE2B 5db95d500a08d656d0221a474d297c8357712f19334f45db347e36f14a10365d65777e0d24c68f75d4855b3ee1778dca1ecf4a05b19d2dd3975acf25a12b4523 SHA512 27261bc875c881495a9b0e1fffc811dff40b763a9e6453ca47143cb8d7d867682becd7266f8d559ad8c32bb5d7de9698341055d483f3e6a68b107895aa174b77
diff --git a/dev-util/systemtap/systemtap-4.9.ebuild b/dev-util/systemtap/systemtap-4.9.ebuild
new file mode 100644
index 000000000000..ce5f554710b0
--- /dev/null
+++ b/dev-util/systemtap/systemtap-4.9.ebuild
@@ -0,0 +1,127 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit autotools linux-info python-single-r1
+
+DESCRIPTION="A linux trace/probe tool"
+HOMEPAGE="https://www.sourceware.org/systemtap"
+SRC_URI="https://www.sourceware.org/ftp/${PN}/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="libvirt selinux sqlite +ssl test zeroconf"
+
+CDEPEND="
+ ${PYTHON_DEPS}
+
+ dev-libs/boost:=
+ >=dev-libs/elfutils-0.142
+ dev-libs/json-c:=
+ sys-libs/ncurses:=
+ sys-libs/readline:=
+
+ libvirt? ( >=app-emulation/libvirt-1.0.2 )
+ selinux? ( sys-libs/libselinux )
+ sqlite? ( dev-db/sqlite:3 )
+ ssl? (
+ dev-libs/nspr
+ dev-libs/nss
+ )
+ zeroconf? ( net-dns/avahi )
+"
+DEPEND="
+ ${CDEPEND}
+ app-arch/cpio
+ app-text/xmlto
+ $(python_gen_cond_dep 'dev-python/setuptools[${PYTHON_USEDEP}]')
+ >=sys-devel/gettext-0.18.2
+
+ libvirt? ( dev-libs/libxml2 )
+"
+RDEPEND="
+ ${CDEPEND}
+ acct-group/stapdev
+ acct-group/stapsys
+ acct-group/stapusr
+"
+BDEPEND="test? ( dev-util/dejagnu )"
+
+CONFIG_CHECK="~KPROBES ~RELAY ~DEBUG_FS"
+ERROR_KPROBES="${PN} requires support for KProbes Instrumentation (KPROBES) - this can be enabled in 'Instrumentation Support -> Kprobes'."
+ERROR_RELAY="${PN} works with support for user space relay support (RELAY) - this can be enabled in 'General setup -> Kernel->user space relay support (formerly relayfs)'."
+ERROR_DEBUG_FS="${PN} works best with support for Debug Filesystem (DEBUG_FS) - this can be enabled in 'Kernel hacking -> Debug Filesystem'."
+
+DOCS="AUTHORS HACKING NEWS README"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+PATCHES=(
+ "${FILESDIR}/${PN}-3.1-ia64.patch"
+)
+
+pkg_setup() {
+ linux-info_pkg_setup
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ python_fix_shebang .
+
+ sed -i \
+ -e 's|-Werror||g' \
+ configure.ac \
+ Makefile.am \
+ stapbpf/Makefile.am \
+ stapdyn/Makefile.am \
+ staprun/Makefile.am \
+ testsuite/systemtap.unprivileged/unprivileged_probes.exp \
+ testsuite/systemtap.unprivileged/unprivileged_myproc.exp \
+ testsuite/systemtap.base/stmt_rel_user.exp \
+ testsuite/systemtap.base/sdt_va_args.exp \
+ testsuite/systemtap.base/sdt_misc.exp \
+ testsuite/systemtap.base/sdt.exp \
+ scripts/kprobes_test/gen_code.py \
+ || die "Failed to clean up sources"
+
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-docs
+ --disable-grapher
+ --disable-refdocs
+ --disable-server
+ # Our toolchain sets this for us already and adding in
+ # -D_FORTIFY_SOURCE=2 breaks builds w/ no optimisation.
+ # This option (at least as of 4.5) doesn't pass -fno* etc,
+ # it just doesn't _add_ options, which is good. If it changes
+ # to actually pass -fno-stack-protector and friends, we'll
+ # need to change course. Forcing =2 also has problems for
+ # setting it to 3.
+ # bug #794667.
+ --disable-ssp
+ --enable-pie
+ --with-python3
+ --without-java
+ --without-openssl
+ --without-python2-probes
+ --without-rpm
+ $(use_enable libvirt virt)
+ $(use_enable sqlite)
+ $(use_with zeroconf avahi)
+ $(use_with ssl nss)
+ $(use_with selinux)
+ )
+ PYTHON3="${PYTHON}" econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ python_optimize
+}