summaryrefslogtreecommitdiff
path: root/dev-util/stripe-mock
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
commit536c3711867ec947c1738f2c4b96f22e4863322d (patch)
tree697733f5cb713908dcf378e13fd15a798a906a91 /dev-util/stripe-mock
parentf65628136faa35d0c4d3b5e7332275c7b35fcd96 (diff)
gentoo resync : 18.11.2018
Diffstat (limited to 'dev-util/stripe-mock')
-rw-r--r--dev-util/stripe-mock/Manifest3
-rw-r--r--dev-util/stripe-mock/metadata.xml15
-rw-r--r--dev-util/stripe-mock/stripe-mock-0.34.1.ebuild22
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-util/stripe-mock/Manifest b/dev-util/stripe-mock/Manifest
new file mode 100644
index 000000000000..eb31240fa3a9
--- /dev/null
+++ b/dev-util/stripe-mock/Manifest
@@ -0,0 +1,3 @@
+DIST stripe-mock-0.34.1.tar.gz 340357 BLAKE2B 127d39b01bbd883141c75e63dc5e0b8834dbc86f375058768072b3de75d3f9e3fabebdfdd9d872c51ad52fec3e2057ae342887c25b496b987d64652c93b204bd SHA512 c9e35867c44bd7d127f91d0f668d39ff67ca9bb2937428f808122555360a77b91f9f5d5648478dc2c4fc04a7b9195fed0a927868fdd22b852022ae2fe0f1e695
+EBUILD stripe-mock-0.34.1.ebuild 579 BLAKE2B bee1b559fd7bd252da8bc9cf95b221c3359841d9653d83add51098699e2a5e44cee1f16d30278270ca6dd5a0a1721b1757be88ce498bfe09622d8c81ac39047e SHA512 c94a200b1976687bf500a5f9a11ab0dc21eaf06aaec2a3d469f2275f3fc20779677c7d679ea220a6f7a8b72061734d215cdfe6bf2f39f6cd79a7b28b10b011aa
+MISC metadata.xml 478 BLAKE2B d9507af9f6fb1e2aefb92dd06000d1043d1f3e022c3c1538cb59da9e8ae79afbcc9485bc7ccb3f607704c9db9cd927a944e85f96a8fb8603491f7e464345fc0f SHA512 9f8e49eaebacbc8dcde06ca7650654f95e33e3bef44e7eb6106e128accb4a809a364c0c3aa6cf93be2ea0e8510774c8f5bcde4cc72af269e6644dde44f21b5b8
diff --git a/dev-util/stripe-mock/metadata.xml b/dev-util/stripe-mock/metadata.xml
new file mode 100644
index 000000000000..afb8d27c3fa7
--- /dev/null
+++ b/dev-util/stripe-mock/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>m.seifert@digitalernachschub.de</email>
+ <name>Michael Seifert</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">stripe/stripe-mock</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-util/stripe-mock/stripe-mock-0.34.1.ebuild b/dev-util/stripe-mock/stripe-mock-0.34.1.ebuild
new file mode 100644
index 000000000000..9e701cfd247e
--- /dev/null
+++ b/dev-util/stripe-mock/stripe-mock-0.34.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGO_SRC="github.com/stripe/stripe-mock"
+EGO_PN=${EGO_SRC}/...
+inherit golang-build golang-vcs-snapshot
+
+DESCRIPTION="Mock HTTP server that responds like the real Stripe API"
+HOMEPAGE="https://github.com/stripe/stripe-mock"
+SRC_URI="https://github.com/stripe/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="MIT"
+SLOT="0"
+
+src_install() {
+ golang-build_src_install
+ dobin bin/stripe-mock
+ rm -rf "${D%/}$(get_golibdir_gopath)" || die
+}