summaryrefslogtreecommitdiff
path: root/dev-util/stripe-mock/stripe-mock-0.184.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-13 12:04:20 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-13 12:04:20 +0100
commitd993571e2ee444d08f4e9e90d493ee37338657e3 (patch)
tree5a49a1d4ceffe800051e363f64571c3b6735d2f7 /dev-util/stripe-mock/stripe-mock-0.184.0.ebuild
parent266d65d0cceeb55ab2cc3bf4e465d7f35502a900 (diff)
gentoo auto-resync : 13:04:2024 - 12:04:19
Diffstat (limited to 'dev-util/stripe-mock/stripe-mock-0.184.0.ebuild')
-rw-r--r--dev-util/stripe-mock/stripe-mock-0.184.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-util/stripe-mock/stripe-mock-0.184.0.ebuild b/dev-util/stripe-mock/stripe-mock-0.184.0.ebuild
new file mode 100644
index 000000000000..352d14e2ce00
--- /dev/null
+++ b/dev-util/stripe-mock/stripe-mock-0.184.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Mock HTTP server that responds like the real Stripe API"
+HOMEPAGE="https://github.com/stripe/stripe-mock/"
+SRC_URI="https://github.com/stripe/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT ISC BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+src_compile() {
+ emake build
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ dobin stripe-mock
+ einstalldocs
+}