summaryrefslogtreecommitdiff
path: root/dev-util/stressapptest/stressapptest-1.0.11.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-19 03:53:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-19 03:53:34 +0100
commita643f0010255d34e6b8045aba39aef5174921a7d (patch)
tree0531d8d403536c7aaac699a54873e5111d7f4035 /dev-util/stressapptest/stressapptest-1.0.11.ebuild
parent99c41a033e7745ed8aa9ffbf0f9e1e414e80da4a (diff)
gentoo auto-resync : 19:10:2023 - 03:53:34
Diffstat (limited to 'dev-util/stressapptest/stressapptest-1.0.11.ebuild')
-rw-r--r--dev-util/stressapptest/stressapptest-1.0.11.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-util/stressapptest/stressapptest-1.0.11.ebuild b/dev-util/stressapptest/stressapptest-1.0.11.ebuild
new file mode 100644
index 000000000000..ef8787eafda4
--- /dev/null
+++ b/dev-util/stressapptest/stressapptest-1.0.11.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic
+
+DESCRIPTION="Stressful Application Test"
+HOMEPAGE="https://github.com/stressapptest/stressapptest"
+SRC_URI="https://github.com/stressapptest/stressapptest/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~x86"
+IUSE="debug"
+
+RDEPEND="dev-libs/libaio"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ # Matches the configure & sat.cc logic
+ use debug || append-cppflags -DNDEBUG -DCHECKOPTS
+ econf --disable-default-optimizations
+}