summaryrefslogtreecommitdiff
path: root/dev-util/stepman/stepman-0.10.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-21 18:59:32 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-21 18:59:32 +0100
commit520a5b56dff7c24c9d42eafec142cb78b44f8e3e (patch)
treef562f705600dbd2292e97c0b4145787c2a8d1f97 /dev-util/stepman/stepman-0.10.0.ebuild
parent3811bc3072bf19e2be351d2c63f81532945c0f21 (diff)
gentoo resync : 21.07.2018
Diffstat (limited to 'dev-util/stepman/stepman-0.10.0.ebuild')
-rw-r--r--dev-util/stepman/stepman-0.10.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-util/stepman/stepman-0.10.0.ebuild b/dev-util/stepman/stepman-0.10.0.ebuild
new file mode 100644
index 000000000000..4b0b891bc494
--- /dev/null
+++ b/dev-util/stepman/stepman-0.10.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit golang-build
+
+EGO_ON="github.com/bitrise-io"
+EGO_PN="${EGO_ON}/${PN}"
+
+DESCRIPTION="Step collection manager for Bitrise CLI."
+HOMEPAGE="https://www.bitrise.io/cli"
+SRC_URI="https://${EGO_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+S="${WORKDIR}/src/${EGO_ON}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ mkdir -p "${WORKDIR}/src/${EGO_ON}" || die "Couldn't create project dir in GOPATH"
+ mv "${WORKDIR}/${P}" "${WORKDIR}/src/${EGO_ON}/stepman" || die "Couldn't move sources to GOPATH"
+}
+
+src_compile() {
+ GOPATH="${WORKDIR}" go build -v -o bin/stepman || die "Couldn't compile stepman"
+}
+
+src_test() {
+ export INTEGRATION_TEST_BINARY_PATH="${S}/bin/stepman"
+ GOPATH="${WORKDIR}" go test -v ./_tests/integration/... || die "Integration tests failed"
+}
+
+src_install() {
+ dobin bin/stepman
+ dodoc README.md
+}