summaryrefslogtreecommitdiff
path: root/dev-util/squashmerge/squashmerge-0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /dev-util/squashmerge/squashmerge-0.1.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'dev-util/squashmerge/squashmerge-0.1.ebuild')
-rw-r--r--dev-util/squashmerge/squashmerge-0.1.ebuild17
1 files changed, 7 insertions, 10 deletions
diff --git a/dev-util/squashmerge/squashmerge-0.1.ebuild b/dev-util/squashmerge/squashmerge-0.1.ebuild
index b2b4863ee107..b85491ed9427 100644
--- a/dev-util/squashmerge/squashmerge-0.1.ebuild
+++ b/dev-util/squashmerge/squashmerge-0.1.ebuild
@@ -1,18 +1,18 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-
-inherit autotools-utils
+EAPI=7
DESCRIPTION="dev-util/squashdelta delta merge tool"
HOMEPAGE="https://github.com/mgorny/squashmerge/"
-SRC_URI="https://www.github.com/mgorny/${PN}/releases/download/v${PV}/${P}.tar.bz2"
+SRC_URI="https://github.com/mgorny/${PN}/releases/download/v${PV}/${P}.tar.bz2"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="lz4 +lzo"
+# SquashDelta does not make much sense without a compression algo.
+REQUIRED_USE="|| ( lz4 lzo )"
COMMON_DEPEND="
lz4? ( app-arch/lz4:0= )
@@ -21,16 +21,13 @@ RDEPEND="${COMMON_DEPEND}
dev-util/xdelta:3"
DEPEND=${COMMON_DEPEND}
-# SquashDelta does not make much sense without a compression algo.
-REQUIRED_USE="|| ( lz4 lzo )"
-
DOCS=( FORMAT )
src_configure() {
- local myeconfargs=(
+ local myconf=(
$(use_enable lz4)
$(use_enable lzo)
)
- autotools-utils_src_configure
+ econf "${myconf[@]}"
}