summaryrefslogtreecommitdiff
path: root/dev-util/spec-cleaner/spec-cleaner-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-05 21:52:00 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-05 21:52:00 +0100
commit2d446203bcf1a0db08e99abca43513d246dfa73d (patch)
treeec623bb5f1f389976977e375342ec59ff441eab7 /dev-util/spec-cleaner/spec-cleaner-9999.ebuild
parent171a011ad3a131671aeb5a98b9e3adf219ad2865 (diff)
gentoo resync : 05.04.2018
Diffstat (limited to 'dev-util/spec-cleaner/spec-cleaner-9999.ebuild')
-rw-r--r--dev-util/spec-cleaner/spec-cleaner-9999.ebuild19
1 files changed, 12 insertions, 7 deletions
diff --git a/dev-util/spec-cleaner/spec-cleaner-9999.ebuild b/dev-util/spec-cleaner/spec-cleaner-9999.ebuild
index 61a6579ab757..297d0528ae6b 100644
--- a/dev-util/spec-cleaner/spec-cleaner-9999.ebuild
+++ b/dev-util/spec-cleaner/spec-cleaner-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
-PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+PYTHON_COMPAT=( python{3_4,3_5} )
EGIT_REPO_URI="https://github.com/openSUSE/spec-cleaner.git"
inherit distutils-r1
[[ ${PV} == 9999 ]] && inherit git-r3
@@ -14,20 +14,25 @@ HOMEPAGE="https://github.com/openSUSE/spec-cleaner"
LICENSE="BSD"
SLOT="0"
-[[ ${PV} != 9999 ]] && \
+[[ ${PV} != 9999 ]] &&
KEYWORDS="~amd64 ~x86"
IUSE="test"
DEPEND="
test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
)
"
RDEPEND="
${PYTHON_DEPS}
+ >=app-arch/rpm-4.11.0.1
"
+PATCHES=(
+ # pytest-runner is only needed in test scenario
+ "${FILESDIR}/${PN}-1.0.6-pytest-runner.patch"
+)
+
[[ ${PV} != 9999 ]] && S="${WORKDIR}/${PN}-${P}"
src_prepare() {
@@ -39,5 +44,5 @@ src_prepare() {
}
python_test() {
- nosetests
+ esetup.py test
}