summaryrefslogtreecommitdiff
path: root/dev-util/smem/smem-1.5-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
commit7f0ccc917c7abe6223784c703d86cd14755691fb (patch)
tree8c6793f68896b341e22f33d7e6cef88e481f4a8b /dev-util/smem/smem-1.5-r1.ebuild
parent9aa80713372911cec499b3adb2cd746790920916 (diff)
gentoo resync : 03.07.2021
Diffstat (limited to 'dev-util/smem/smem-1.5-r1.ebuild')
-rw-r--r--dev-util/smem/smem-1.5-r1.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/dev-util/smem/smem-1.5-r1.ebuild b/dev-util/smem/smem-1.5-r1.ebuild
index a31a893131b2..539ed4ae1b7a 100644
--- a/dev-util/smem/smem-1.5-r1.ebuild
+++ b/dev-util/smem/smem-1.5-r1.ebuild
@@ -1,16 +1,17 @@
-# Copyright 2019-2020 Gentoo Authors
+# Copyright 2019-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
EGIT_COMMIT="2ab5040d5633"
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit optfeature python-single-r1 toolchain-funcs
DESCRIPTION="A tool that can give numerous reports on memory usage on Linux systems"
HOMEPAGE="https://www.selenic.com/smem/"
SRC_URI="https://selenic.com/repo/${PN}/archive/${EGIT_COMMIT}.tar.bz2 -> ${P}.tar.bz2"
+S="${WORKDIR}/${PN}-${EGIT_COMMIT}"
LICENSE="GPL-2+"
SLOT="0"
@@ -20,8 +21,6 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="${PYTHON_DEPS}"
BDEPEND="${RDEPEND}"
-S="${WORKDIR}/${PN}-${EGIT_COMMIT}"
-
src_compile() {
"$(tc-getCC)" ${CFLAGS} ${LDFLAGS} -o smemcap smemcap.c || die
}