summaryrefslogtreecommitdiff
path: root/dev-util/shellcheck-bin/shellcheck-bin-0.9.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-14 03:28:58 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-14 03:28:58 +0000
commitc73b611d606bc14760bad8592f5bfec28c9b1079 (patch)
tree6da7421d10ecff1c38c3774f9a9eed715711fd7c /dev-util/shellcheck-bin/shellcheck-bin-0.9.0.ebuild
parentb9d995791a762215ef1ced2cc1a47b8d3c2cff1a (diff)
gentoo auto-resync : 14:12:2022 - 03:28:57
Diffstat (limited to 'dev-util/shellcheck-bin/shellcheck-bin-0.9.0.ebuild')
-rw-r--r--dev-util/shellcheck-bin/shellcheck-bin-0.9.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-util/shellcheck-bin/shellcheck-bin-0.9.0.ebuild b/dev-util/shellcheck-bin/shellcheck-bin-0.9.0.ebuild
new file mode 100644
index 000000000000..e4b6825e8e0e
--- /dev/null
+++ b/dev-util/shellcheck-bin/shellcheck-bin-0.9.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN=${PN/-bin/}
+BASE_URI="https://github.com/koalaman/${MY_PN}/releases/download/v${PV}/${MY_PN}-v${PV}.linux"
+
+DESCRIPTION="Shell script analysis tool (binary package)"
+HOMEPAGE="https://www.shellcheck.net/"
+SRC_URI="
+ amd64? ( "${BASE_URI}".x86_64.tar.xz )
+ arm? ( "${BASE_URI}".armv6hf.tar.xz )
+ arm64? ( "${BASE_URI}".aarch64.tar.xz )
+"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~arm ~arm64"
+
+DEPEND="!dev-util/shellcheck"
+RDEPEND="${DEPEND}"
+
+QA_PREBUILT="/usr/bin/shellcheck"
+S="${WORKDIR}/${MY_PN}-v${PV}"
+
+src_install() {
+ dobin shellcheck
+ einstalldocs
+}