summaryrefslogtreecommitdiff
path: root/dev-util/shellcheck-bin/shellcheck-bin-0.5.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-30 11:19:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-30 11:19:18 +0100
commit62f67115b5c46134c34f88f4b1cbdacc19384c0a (patch)
tree0a76b14de203a4c23040e5665e39df8de9867745 /dev-util/shellcheck-bin/shellcheck-bin-0.5.0.ebuild
parent265dbe5dbc14c199299496c6db8fce3f76647015 (diff)
gentoo resync : 30.09.2018
Diffstat (limited to 'dev-util/shellcheck-bin/shellcheck-bin-0.5.0.ebuild')
-rw-r--r--dev-util/shellcheck-bin/shellcheck-bin-0.5.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-util/shellcheck-bin/shellcheck-bin-0.5.0.ebuild b/dev-util/shellcheck-bin/shellcheck-bin-0.5.0.ebuild
new file mode 100644
index 000000000000..633eb0107655
--- /dev/null
+++ b/dev-util/shellcheck-bin/shellcheck-bin-0.5.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN=${PN/-bin/}
+
+DESCRIPTION="Shell script analysis tool (binary package)"
+HOMEPAGE="https://www.shellcheck.net/"
+SRC_URI="https://storage.googleapis.com/${MY_PN}/${MY_PN}-v${PV}.linux.x86_64.tar.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="!dev-util/shellcheck"
+RDEPEND="${DEPEND}"
+
+QA_PREBUILT="/usr/bin/shellcheck"
+S="${WORKDIR}/${MY_PN}-v${PV}"
+
+src_install() {
+ dobin shellcheck
+ einstalldocs
+}