summaryrefslogtreecommitdiff
path: root/dev-util/shadowman/shadowman-3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-11-03 06:47:15 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-11-03 06:47:15 +0000
commitfc2f1018fc323ef2c6572734a9b130427cba76a6 (patch)
treef834bdc9a67923ce75297c09d00d1e7b90791d26 /dev-util/shadowman/shadowman-3.ebuild
parent162945d2a91899b637bbb9e163b406350de12906 (diff)
gentoo resync : 03.11.2021
Diffstat (limited to 'dev-util/shadowman/shadowman-3.ebuild')
-rw-r--r--dev-util/shadowman/shadowman-3.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-util/shadowman/shadowman-3.ebuild b/dev-util/shadowman/shadowman-3.ebuild
new file mode 100644
index 000000000000..f7b929689cf0
--- /dev/null
+++ b/dev-util/shadowman/shadowman-3.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Unified compiler shadow link directory updater"
+HOMEPAGE="https://github.com/mgorny/shadowman"
+SRC_URI="https://github.com/mgorny/shadowman/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="app-admin/eselect"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ # tool modules are split into their respective packages
+ emake DESTDIR="${D}" prefix="${EPREFIX}"/usr install \
+ INSTALL_MODULES_TOOL=""
+ keepdir /usr/share/shadowman/tools
+}