summaryrefslogtreecommitdiff
path: root/dev-util/sh/sh-3.5.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-25 10:31:10 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-25 10:31:10 +0000
commit2900e684ae4bdce1f20652587728095cd01a30a1 (patch)
treedb7b5054b7d0de362a2960a0a7268ffc37b8e1f9 /dev-util/sh/sh-3.5.1.ebuild
parentff8c6e4babf1a2911b8d61b6bb7e80290355cb70 (diff)
gentoo auto-resync : 25:11:2023 - 10:31:10
Diffstat (limited to 'dev-util/sh/sh-3.5.1.ebuild')
-rw-r--r--dev-util/sh/sh-3.5.1.ebuild54
1 files changed, 0 insertions, 54 deletions
diff --git a/dev-util/sh/sh-3.5.1.ebuild b/dev-util/sh/sh-3.5.1.ebuild
deleted file mode 100644
index ea48ab9e9b7d..000000000000
--- a/dev-util/sh/sh-3.5.1.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit go-module
-
-DESCRIPTION="A shell parser, formatter, and interpreter with bash support"
-HOMEPAGE="https://github.com/mvdan/sh"
-
-if [[ ${PV} == *9999 ]]; then
- EGIT_REPO_URI="https://github.com/mvdan/sh.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/mvdan/sh/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
- SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"
- KEYWORDS="~amd64 ~arm64 ~x86"
- S="${WORKDIR}/${PN//fmt/}-${PV}"
-fi
-
-LICENSE="Apache-2.0 BSD"
-SLOT="0"
-IUSE="+man"
-
-BDEPEND="man? ( app-text/scdoc )"
-
-src_unpack() {
- default
- if [[ ${PV} == *9999 ]]; then
- git-r3_src_unpack
- go-module_live_vendor
- fi
-}
-
-src_compile() {
- # Not bothering with gosh for now as it's very new
- # https://github.com/mvdan/sh#gosh
- ego build ./cmd/shfmt
- if use man; then
- scdoc <cmd/shfmt/shfmt.1.scd >shfmt.1 || die "conversation of man page failed"
- fi
-}
-
-src_test() {
- cd syntax || die
- ego test -run=-
-}
-
-src_install() {
- dobin shfmt
- if use man; then
- doman shfmt.1
- fi
-}