summaryrefslogtreecommitdiff
path: root/dev-util/sh/sh-3.5.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-26 14:59:08 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-26 14:59:08 +0100
commit1503b28e7a30c164cab750c27268f704b8a5cec6 (patch)
treed06a47a18b0fb792e95f88ea6e18af234eb0b9d5 /dev-util/sh/sh-3.5.1.ebuild
parent34ce8f465101950c92cb66c657d3244b5a8397db (diff)
gentoo auto-resync : 26:07:2022 - 14:59:07
Diffstat (limited to 'dev-util/sh/sh-3.5.1.ebuild')
-rw-r--r--dev-util/sh/sh-3.5.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-util/sh/sh-3.5.1.ebuild b/dev-util/sh/sh-3.5.1.ebuild
new file mode 100644
index 000000000000..f5098aea771b
--- /dev/null
+++ b/dev-util/sh/sh-3.5.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="A shell parser, formatter, and interpreter with bash support"
+HOMEPAGE="https://github.com/mvdan/sh"
+SRC_URI="https://github.com/mvdan/sh/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0 BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_compile() {
+ # Not bothering with gosh for now as it's very new
+ # https://github.com/mvdan/sh#gosh
+ ego build ./cmd/shfmt
+}
+
+src_test() {
+ cd syntax || die
+ ego test -run=-
+}
+
+src_install() {
+ dobin shfmt
+}