summaryrefslogtreecommitdiff
path: root/dev-util/setconf
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-util/setconf
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-util/setconf')
-rw-r--r--dev-util/setconf/Manifest5
-rw-r--r--dev-util/setconf/metadata.xml8
-rw-r--r--dev-util/setconf/setconf-0.6.6.ebuild39
-rw-r--r--dev-util/setconf/setconf-0.6.7.ebuild39
4 files changed, 91 insertions, 0 deletions
diff --git a/dev-util/setconf/Manifest b/dev-util/setconf/Manifest
new file mode 100644
index 000000000000..70fc98675150
--- /dev/null
+++ b/dev-util/setconf/Manifest
@@ -0,0 +1,5 @@
+DIST setconf-0.6.6.tar.xz 12620 BLAKE2B 2882c50430a65e6947135808f87674c19bb8a57d0f5ecbb9d3e316b203b359bb79503b1e68931bfac04e52d3d0686fc11f0c74aa4d84797a0d44f8989c26b4cf SHA512 28f62b4dbc5883763cd11480ca059dd8ba120d6dfd964bbf1746ec5cb23fb0f0fd949249f77673d150cb6abd0039ff6f34d79ad744f8abcc765e0af37fbb85ff
+DIST setconf-0.6.7.tar.xz 12700 BLAKE2B 9dd3625f3fa2345ba6f9cb21fffae770a257928c2287e1772f92d831e9b6c09d8c5b09118a146b6704bb5003dd02fb0793ecabc7d8a2410f4f3941bd687b3a14 SHA512 8b247de9f7ac06f77e6251e95c045886cde5b6ca21b0152cb6fdc1456381aacd9051d5221c9fc8149608555e14f85ee2b51acbe65f78d129b1c8b732e093236d
+EBUILD setconf-0.6.6.ebuild 834 BLAKE2B 4c4b2547166426976e5b2c2627c535d6b982716fe979b10ee91279d4721f03eb63995bb25773f5550b68f6207e18d1aa5514974133b622323fc96650ddd08217 SHA512 c5752e1c0685d7bcaac043b5d754ab57d26b06f86f58c58cd1f6e95a878af678a2c8fd4a0eaadc606d4d36272e974bb06a45fe8c486c79b10a566bd27a9adfb3
+EBUILD setconf-0.6.7.ebuild 842 BLAKE2B a294df3d635e6835ef36609721b37eba671326a2c0f5ea980336e1bec76b8b5cd17a2fa8cbb162dc8252d18ed45f189972cc7e9c1987f351dbc0b073b0e1d439 SHA512 221d62759fb5cd629aa00e63634b5b9be3a4925c75a2f86c2d6f77656ee0a4f214b836334a1e9bf7f5962c7bdd4053087f94b775326969b7c52d2a79489b5abd
+MISC metadata.xml 265 BLAKE2B 75452ad720a31a08fc0dcd02eec704c18b11bc0660686f9a320b85fc879f55a564ce9c3b6a8c710781b74c5e8eb3d0544c02a042fb35a0b62a5e1491f675296a SHA512 176f814d8c555e8726f36e012367b698e8a19a0662982621029a7f9190beecc5e6798e43c51698dc149364966cdeff7061121e54fa9d4cf2a3559a6ce4904e25
diff --git a/dev-util/setconf/metadata.xml b/dev-util/setconf/metadata.xml
new file mode 100644
index 000000000000..3cf14bf74636
--- /dev/null
+++ b/dev-util/setconf/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>shell-tools@gentoo.org</email>
+ <name>Gentoo Shell Tools Project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-util/setconf/setconf-0.6.6.ebuild b/dev-util/setconf/setconf-0.6.6.ebuild
new file mode 100644
index 000000000000..b0646c4fed59
--- /dev/null
+++ b/dev-util/setconf/setconf-0.6.6.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4} )
+inherit python-single-r1
+
+DESCRIPTION="A small python based utility used to change configuration files"
+HOMEPAGE="http://setconf.roboticoverlords.org/"
+SRC_URI="http://${PN}.roboticoverlords.org/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=${PYTHON_DEPS}
+
+# "REQUIRED_USE is needed to have a (un-)nice error when someone disabled all of python3" -mgorny
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}" || die
+ unpack "./${PN}.1.gz"
+}
+
+src_prepare() {
+ python_fix_shebang -f "${PN}.py"
+}
+
+src_install() {
+ python_doscript "${PN}.py"
+ dosym "${PN}.py" "/usr/bin/${PN}"
+ doman "${PN}.1"
+}
diff --git a/dev-util/setconf/setconf-0.6.7.ebuild b/dev-util/setconf/setconf-0.6.7.ebuild
new file mode 100644
index 000000000000..1f5e27b579f0
--- /dev/null
+++ b/dev-util/setconf/setconf-0.6.7.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+inherit python-single-r1
+
+DESCRIPTION="A small python based utility used to change configuration files"
+HOMEPAGE="http://setconf.roboticoverlords.org/"
+SRC_URI="http://${PN}.roboticoverlords.org/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=${PYTHON_DEPS}
+
+# "REQUIRED_USE is needed to have a (un-)nice error when someone disabled all of python3" -mgorny
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}" || die
+ unpack "./${PN}.1.gz"
+}
+
+src_prepare() {
+ python_fix_shebang -f "${PN}.py"
+}
+
+src_install() {
+ python_doscript "${PN}.py"
+ dosym "${PN}.py" "/usr/bin/${PN}"
+ doman "${PN}.1"
+}