summaryrefslogtreecommitdiff
path: root/dev-util/sel/sel-0.08.4-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-util/sel/sel-0.08.4-r2.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-util/sel/sel-0.08.4-r2.ebuild')
-rw-r--r--dev-util/sel/sel-0.08.4-r2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-util/sel/sel-0.08.4-r2.ebuild b/dev-util/sel/sel-0.08.4-r2.ebuild
new file mode 100644
index 000000000000..62715868b15a
--- /dev/null
+++ b/dev-util/sel/sel-0.08.4-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="A filemanager for shell scripts"
+SRC_URI="http://www.rninet.de/darkstar/files/${P}.tar.gz"
+HOMEPAGE="http://www.rninet.de/darkstar/sel.html"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="amd64 ppc s390 sparc x86"
+
+RDEPEND="sys-libs/ncurses:0="
+
+DOCS=( "help.txt" README.GER whatsnew )
+
+src_prepare () {
+ default
+ sed -i \
+ -e "s:/usr/local/share/sel/help\.txt:/usr/share/sel/help\.txt:" \
+ "${PN}.c" || die 'sed failed'
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDLIBS="-lncurses"
+}
+
+src_install () {
+ dobin "${PN}"
+ doman "${PN}.1"
+ einstalldocs
+}